This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 179020 - dbus hogs cpu
dbus hogs cpu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 12:24 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 00:57:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-01-26 12:24:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.5.1

Description of problem:
dbus-daemon has gone crazy, and is hogging my cpu.

strace | grep denied shows:
readlink("/proc/self/exe", 0xbff492f8, 4095) = -1 EACCES (Permission denied)
readlink("/proc/self/fd/0", 0xbff4e488, 31) = -1 EACCES (Permission denied)
readlink("/proc/self/fd/1", 0xbff4e488, 31) = -1 EACCES (Permission denied)
readlink("/proc/self/fd/2", 0xbff4e488, 31) = -1 EACCES (Permission denied)
sendto(6, " \1\0\0S\4\5\0\346\300\7\0\0\0\0\0avc:  denied  { "..., 288, 0, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 288

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 John (J5) Palmieri 2006-01-26 12:57:39 EST
Looks like an SE-Linux issue.  Are you up to date with rawhide?
Comment 2 Need Real Name 2006-01-26 12:59:06 EST
Yep, and an autorelabel fixes it.

Interestingly, killing dbus made evolution hog the cpu.
An strace of evolution showed almost no activity. Weird.
Comment 3 Daniel Walsh 2006-01-27 00:57:40 EST
Fixed in selinux-policy-2.2.5-1

Note You need to log in before you can comment on or make changes to this bug.