Bug 1790239 - [cockpit-ceph-installer] Only 1 ISO image is shown, when more exist on the installer host
Summary: [cockpit-ceph-installer] Only 1 ISO image is shown, when more exist on the in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 4.0
Hardware: x86_64
OS: All
high
high
Target Milestone: rc
: 4.0
Assignee: Paul Cuzner
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-12 21:27 UTC by Paul Cuzner
Modified: 2020-01-31 12:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:49 UTC

Description Paul Cuzner 2020-01-12 21:27:10 UTC
Description of problem:
If the installer host has >1 ISO image, the UI is only showing one image. This blocks the user from selecting the desired source ISO.

(originally reported by : John Brier)

Version-Release number of selected component (if applicable):
cockpit-ceph-installer v0.9-7

How reproducible:
Every time

Steps to Reproduce:
1. Place a valid ISO image in the /usr/share/ansible-runner-service/iso directory
2. copy and rename to provide multiple iso images in the directory
3. refresh the installer page in the UI
4. Switch to Installation Source - ISO, and look at the available options in target version pull down box

Actual results:
Only one ISO image is shown

Expected results:
pull down should show all available ISO images to select from

Additional info:

Comment 1 Paul Cuzner 2020-01-13 01:50:54 UTC
fix upstream in wip-0.9-8

Comment 2 Yaniv Kaul 2020-01-13 07:00:45 UTC
I don't see why it's high severity. Why would you have multiple ISOs? The workaround is easy - remove the other ISOs, right?

Paul - is that going to be fixed for 4.0? As a bug that is not a blocker, I prefer postponing and moving to 4.1.

QE - please ack.

Comment 9 errata-xmlrpc 2020-01-31 12:48:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.