Bug 1790243 - [cockpit-ceph-installer] Unable to change roles in the add-hosts dialog
Summary: [cockpit-ceph-installer] Unable to change roles in the add-hosts dialog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 4.0
Assignee: Paul Cuzner
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-12 22:26 UTC by Paul Cuzner
Modified: 2020-01-31 12:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github red-hat-storage cockpit-ceph-installer issues 52 0 None closed UI: Unable to change roles in the add hosts page 2020-01-29 02:31:05 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:49 UTC

Description Paul Cuzner 2020-01-12 22:26:33 UTC
Description of problem:
After you have added a host, it is show in the add hosts page - and appears to have role checkboxes that may be selected. However, attempting to click on these checkboxes doesn't update the UI...but does result in the inventory being updated!

Version-Release number of selected component (if applicable):
cockpit-ceph-installer 0.9-7

How reproducible:
100%

Steps to Reproduce:
1. Add a host
2. On the hosts page, attempt to add further roles
3.

Actual results:
No change is visibile in the UI - but checking the inventory, shows that the changes are made

Expected results:
add hosts role checkboxes should update normally


Additional info:

Comment 1 Paul Cuzner 2020-01-13 01:49:24 UTC
fix upstream in wip-0.9-8 branch

Comment 2 Yaniv Kaul 2020-01-13 07:06:09 UTC
Can we postpone to 4.1?

Comment 3 Vasishta 2020-01-14 04:36:40 UTC
Hi Yaniv,

I think i would not be graceful if we ship ceph-installer without the fix and affects usability significantly as creates huge confusion for users and also might result in improper way of cluster creation.

Regards,
Vasishta Shastry
QE, Ceph

Comment 10 Vasishta 2020-01-22 03:36:57 UTC
Added some hosts, try to add&remove roles of a node in hosts page, checkboxes were updated successfully.
Moving to VERIFIED state

Comment 13 errata-xmlrpc 2020-01-31 12:48:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.