Bug 1790276 - project Dashboard Utilization charts keep loading when project is empty [openshift-4.4]
Summary: project Dashboard Utilization charts keep loading when project is empty [open...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-13 02:30 UTC by Yadan Pei
Modified: 2020-05-04 11:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:23:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3906 0 None closed Bug 1790276: Fix utilization loading state if totalQuery is not defined 2020-05-04 06:36:22 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:24:24 UTC

Description Yadan Pei 2020-01-13 02:30:21 UTC
Description of problem:
Project Dashboard Utilization charts keep loading when project is empty

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-01-12-032939

How reproducible:
Always

Steps to Reproduce:
1. User create a new project and view project status on Dashboard


Actual results:
1. The metrics charts in Utilization keeps loading, in F12 we can see it keeps sending requests to get metrics 

Expected results:
1. Show 'no datapoints found' when project is empty, should not send requests repeatly

Additional info:

Comment 2 Yadan Pei 2020-02-03 06:16:47 UTC
1. normal user create a new empty project
2. View project dashboard at Home -> Projects -> userproject -> Utilization table

For empty project, it shows 'No datapoints found' now instead of keep loading

Verified on 4.4.0-0.nightly-2020-02-02-201619

Comment 4 errata-xmlrpc 2020-05-04 11:23:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.