Bug 179038 - Memory leak, appears only if multiple displays are configured
Memory leak, appears only if multiple displays are configured
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 15:21 EST by karsten fischer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:43:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.conf (3.75 KB, text/plain)
2006-01-26 15:22 EST, karsten fischer
no flags Details
Output of 'tail -f /var/log/messages' (3.89 KB, text/html)
2006-01-26 15:24 EST, karsten fischer
no flags Details

  None (edit)
Description karsten fischer 2006-01-26 15:21:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
After successfully configuring my system to use both Monitors as one frambuffer (using the options of xorgs's ati driver, my xorg.conf is included as attachment) I experienced an "Out of Memory" problem regarding gnome-creensaver; this was reported before, but I found out that it only occurs when I use both monitors. My first wild guess: the MergedNonRectangular option of the ati-driver. As a result of this i have a virtual Dektop-size of 2624x1200, which in turn is limited on the secondary display to a y-resolution of 768 via the MergedNonRectangular option. 

Version-Release number of selected component (if applicable):
gnome-screensaver-2.13.5-4; xorg-x11-drv-ati-6.5.7.2-1

How reproducible:
Always

Steps to Reproduce:
1. Start up X using attached xorg.conf
2. Wait for the screensaver 
3. 
  

Actual Results:  Memory was completely eaten up. Once the system was completely unresponsive

Expected Results:  The login-screen should have been waiting for me

Additional info:
Comment 1 karsten fischer 2006-01-26 15:22:52 EST
Created attachment 123739 [details]
My xorg.conf
Comment 2 karsten fischer 2006-01-26 15:24:39 EST
Created attachment 123741 [details]
Output of 'tail -f /var/log/messages'
Comment 3 Rahul Sundaram 2006-02-20 05:46:21 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Red Hat Bugzilla 2007-02-05 14:00:54 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 5 Matthew Miller 2007-04-06 12:25:01 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 6 Ray Strode [halfline] 2007-08-14 11:43:34 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.