Bug 1790508 - The task includes an option with an undefined variable. The error was: 'dict object' has no attribute 'mons'
Summary: The task includes an option with an undefined variable. The error was: 'dict...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks: 1642481
TreeView+ depends on / blocked
 
Reported: 2020-01-13 14:16 UTC by John Fulton
Modified: 2020-01-31 12:48 UTC (History)
10 users (show)

Fixed In Version: ceph-ansible-4.0.9-1.el8cp, ceph-ansible-4.0.9-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
ceph-ansible command log (9.80 KB, application/gzip)
2020-01-13 14:20 UTC, John Fulton
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github /ceph ceph-ansible pull 4924/files 0 None None None 2020-04-01 06:51:09 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:49 UTC

Description John Fulton 2020-01-13 14:16:19 UTC
In ceph-ansible-4.0.8-1.el8cp.noarch ceph-ansible fails with:

        "fatal: [compute-0]: FAILED! => ",
        "  msg: |-",
        "    The task includes an option with an undefined variable. The error was: 
'dict object' has no attribute 'mons'",
        "  ",
        "    The error appears to be in 
'/usr/share/ceph-ansible/roles/ceph-facts/tasks/facts.yml': line 99, column 3, but 
may",
        "    be elsewhere in the file depending on the exact syntax problem.",
        "    The offending line appears to be:",
        "    - name: set_fact _container_exec_cmd",
        "      ^ here",

Might be related to:

https://github.com/ceph/ceph-ansible/commit/d6da508a9b6829d2d0633c7200efdffce14f403f

This was seen in OSP16 CI

 https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/QE/view/OSP16/job/phase2-16_director-rhel-8.1-virthost-3cont_2comp-ipv4-geneve-ceph-external/110/

Comment 1 RHEL Program Management 2020-01-13 14:16:25 UTC
Please specify the severity of this bug. Severity is defined here:
https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity.

Comment 2 John Fulton 2020-01-13 14:20:06 UTC
Created attachment 1651879 [details]
ceph-ansible command log

Comment 6 John Fulton 2020-01-15 01:13:05 UTC
The CI job that produced this error is unable to reproduce the error with the package from the fixed-in

Comment 12 errata-xmlrpc 2020-01-31 12:48:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.