Bug 1790525 - OCP 4.3 Copying directory in DockerFile BuildConfig raise from 1 second to 10 minutes.
Summary: OCP 4.3 Copying directory in DockerFile BuildConfig raise from 1 second to 10...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.3.z
Assignee: Nalin Dahyabhai
QA Contact: wewang
URL:
Whiteboard:
: 1799674 1804405 1807214 (view as bug list)
Depends On: 1788982
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-13 14:37 UTC by Adam Kaplan
Modified: 2020-03-10 23:53 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788982
Environment:
Last Closed: 2020-03-10 23:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift builder pull 127 0 None closed Bug 1790525: bump github.com/containers/{storage,image,buildah} 2021-01-28 09:03:50 UTC
Red Hat Product Errata RHBA-2020:0676 0 None None None 2020-03-10 23:53:17 UTC

Internal Links: 1813258

Comment 1 mchoma 2020-01-30 09:07:25 UTC
Any estimation when this will be fixed? Blocking us (EAP) from moving testing on 4.3.z

Comment 2 Tom Sweeney 2020-01-30 23:18:01 UTC
Any eta on this Nalin?  I know https://github.com/containers/buildah/pull/2072 has merged into Buildah recently to at least help if not cure this, but I don't know when Buildah will merge into OCP

Comment 3 Nalin Dahyabhai 2020-02-11 16:48:33 UTC
(In reply to Tom Sweeney from comment #2)
> Any eta on this Nalin?  I know
> https://github.com/containers/buildah/pull/2072 has merged into Buildah
> recently to at least help if not cure this, but I don't know when Buildah
> will merge into OCP

That's going to be pulled in by https://github.com/openshift/builder/pull/127.

Comment 4 Adam Kaplan 2020-02-18 20:11:31 UTC
*** Bug 1804405 has been marked as a duplicate of this bug. ***

Comment 8 wewang 2020-02-21 03:57:24 UTC
Verified in version:
4.3.0-0.nightly-2020-02-20-190050


steps:
[wewang@wangwen Downloads]$ oc new-app --template=eap-cd-basic-s2i -n wewang5 -p IMAGE_STREAM_NAMESPACE=openshift -p SOURCE_REPOSITORY_URL=https://github.com/jboss-developer/jboss-eap-quickstarts  -p SOURCE_REPOSITORY_REF=openshift -p CONTEXT_DIR=kitchensink
--> Deploying template "wewang5/eap-cd-basic-s2i" to project wewang5

     JBoss EAP CD 18
     ---------
     An example JBoss Enterprise Application Platform continuous delivery application. For more information about using this template, see https://github.com/jboss-container-images/jboss-eap-7-openshift-image/blob/eap-cd/README.adoc

     A new JBoss EAP CD based application has been created in your project.

     * With parameters:
        * Application Name=eap-app
        * Git Repository URL=https://github.com/jboss-developer/jboss-eap-quickstarts
        * Git Reference=openshift
        * Context Directory=kitchensink
        * Galleon layers=
        * Enable ExampleDS datasource=false
        * Queues=
        * Topics=
        * AMQ cluster password=TUHRst1S # generated
        * Github Webhook Secret=WGMjqhk7 # generated
        * Generic Webhook Secret=02gLSKpF # generated
        * ImageStream Namespace=openshift
        * JGroups Cluster Password=JlVK7WII # generated
        * Deploy Exploded Archives=false
        * Maven mirror URL=
        * Maven Additional Arguments=-Dcom.redhat.xpaas.repo.jbossorg
        * ARTIFACT_DIR=
        * MEMORY_LIMIT=1Gi

--> Creating resources ...
    service "eap-app" created
    service "eap-app-ping" created
    route.route.openshift.io "eap-app" created
    imagestream.image.openshift.io "eap-app" created
    imagestream.image.openshift.io "eap-app-build-artifacts" created
    buildconfig.build.openshift.io "eap-app-build-artifacts" created
    buildconfig.build.openshift.io "eap-app" created
    deploymentconfig.apps.openshift.io "eap-app" created
--> Success
    Access your application via route 'eap-app-wewang5.apps.wewang-43bug.qe.devcluster.openshift.com' 
    Build scheduled, use 'oc logs -f bc/eap-app-build-artifacts' to track its progress.
    Build scheduled, use 'oc logs -f bc/eap-app' to track its progress.

[wewang@wangwen Downloads]$ oc  get builds
NAME                        TYPE     FROM            STATUS                        STARTED              DURATION
eap-app-build-artifacts-1   Source   Git@9e54b55     Complete                      4 minutes ago        2m49s
NAME        TYPE     FROM          STATUS     STARTED         DURATION
eap-app-1   Source   Git@9e54b55   Complete   4 minutes ago   3m23s

Comment 9 Adam Kaplan 2020-02-26 16:02:36 UTC
*** Bug 1807214 has been marked as a duplicate of this bug. ***

Comment 10 Nalin Dahyabhai 2020-03-06 19:17:40 UTC
*** Bug 1799674 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.