Bug 1790566 - pdfTeX error: pdflatex (file nto_uwtd6c.enc): cannot open encoding file for reading
Summary: pdfTeX error: pdflatex (file nto_uwtd6c.enc): cannot open encoding file for r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-13 16:06 UTC by Ankur Sinha (FranciscoD)
Modified: 2020-01-20 01:43 UTC (History)
3 users (show)

Fixed In Version: texlive-2019-15.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-20 01:43:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Ankur Sinha (FranciscoD) 2020-01-13 16:06:09 UTC
Description of problem:
The texlive-noto package no longer includes the `/usr/share/texlive/texmf-dist/fonts/enc/dvips/noto/nto_uwtd6c.enc` file. This causes compilation of latex documents using the noto fonts to fail:

{/usr/share/texlive/texmf-dist/fonts/enc/dvips/noto/nto_cwvxtj.enc}
!pdfTeX error: pdflatex (file nto_uwtd6c.enc): cannot open encoding file for re
ading
 ==> Fatal error occurred, no output PDF file produced!


Version-Release number of selected component (if applicable):
texlive-noto-svn51202-13.fc31.noarch
texlive-2019-13.fc31.noarch

How reproducible:
Always---but on this rather complex document (my dissertation), unable to supply a MWE unfortunately.

Steps to Reproduce:
1. NA
2. 
3.

Actual results:
Compilation fails because of the missing enc file.

Expected results:
File should be found and compilation should succeed (I think?).

Additional info:
The older version of texlive-noto did include the file:

$ sudo dnf whatprovides /usr/share/texlive/texmf-dist/fonts/enc/dvips/noto/nto_uwtd6c.enc
[sudo] password for asinha:
Last metadata expiration check: 1:23:32 ago on Mon 13 Jan 2020 14:08:09 GMT.
texlive-noto-8:svn46687-27.fc31.noarch : Support for Noto fonts
Repo        : fedora
Matched from:
Filename    : /usr/share/texlive/texmf-dist/fonts/enc/dvips/noto/nto_uwtd6c.enc


I downloaded the current texlive-noto package from ctan (2019-12-05), and that seems to include it too:

https://ctan.org/pkg/noto

$ ls
doc  enc  latex  map  README  tfm  truetype  type1  vf
$ ls enc/ | grep uwtd6
nto_uwtd6c.enc



But, the current rpm does not:
$ rpm -q texlive-noto
texlive-noto-svn51202-13.fc31.noarch
$ rpmls texlive-noto | grep uwtd6


I did try a quick downgrade of texlive-noto but that gave me some other errors, so that doesn't work as a quick-fix.

Comment 1 Tom "spot" Callaway 2020-01-13 20:17:32 UTC
Can you give me the full error log? That file is definitely gone (and the provides on the texlive-noto package are incorrect), but I need to figure out what other file has it hardcoded.

Comment 2 Tom "spot" Callaway 2020-01-13 20:37:00 UTC
Never mind. Looks like this was an issue in the noto tarball I pulled down that is now fixed in the current one, just going to update to the current one.

Comment 3 Fedora Update System 2020-01-16 19:51:06 UTC
texlive-2019-14.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-cbbb51f024

Comment 4 Fedora Update System 2020-01-20 01:43:35 UTC
texlive-2019-15.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.