Bug 1790629 - Cluster fails to install - "Could not update list"
Summary: Cluster fails to install - "Could not update list"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-13 19:13 UTC by Adam Kaplan
Modified: 2020-05-04 11:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:24:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-version-operator pull 302 0 None closed Bug 1790629: use st.Manifest.OriginalFilename if object doesn't have a name 2020-04-23 18:19:21 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:24:32 UTC

Description Adam Kaplan 2020-01-13 19:13:47 UTC
Description of problem:

CVO fails to complete the installation with error message:
```
level=fatal msg=failed to initialize the cluster: Could not update list \"\" (188 of 529)"
```

This is not a usable or actionable error message. CVO logs do not clearly indicate which operator is failing.

Version-Release number of the following components: 4.4.0

How reproducible: Sometimes

Additional Info:

1. https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_cluster-image-registry-operator/407/pull-ci-openshift-cluster-image-registry-operator-master-e2e-aws/2139
2. https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_cluster-image-registry-operator/407/pull-ci-openshift-cluster-image-registry-operator-master-e2e-aws-image-registry/1467

Comment 1 Vadim Rutkovsky 2020-01-13 19:47:55 UTC
This happened because a List object was added - https://github.com/openshift/cluster-image-registry-operator/pull/407/files#diff-88bbb853bcd5a5fbc188c46767630fad. 

CVO would display object's kind and name. This List doesn't have "name" set, but other than that its a valid object.

Not sure if this is a valid bug though, as its not clear what should CVO show for Lists without names. Perhaps oc should ensure each manifest object should have "name" set?

Comment 2 Adam Kaplan 2020-01-16 22:07:52 UTC
@Vadim this is a bug per the following:

> This is not a usable or actionable error message. CVO logs do not clearly indicate which operator is failing.

This might be a "dev only" issue - we won't ship a version of OpenShift that fails installation on a supported provider/environment. In the case of an unsupported type (`List`), we should log the name of the manifest file the CVO was trying to apply.

Comment 4 Johnny Liu 2020-02-11 08:56:50 UTC
QE can not reproduce this bug. Run a regression, everything is going well. No regression.

Comment 5 Johnny Liu 2020-02-11 08:59:10 UTC
Verification on 4.4.0-0.nightly-2020-02-09-220310

Comment 7 errata-xmlrpc 2020-05-04 11:24:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.