Bug 179065 - ifup-aliases doesn't check ONBOOT
ifup-aliases doesn't check ONBOOT
Status: CLOSED DUPLICATE of bug 155497
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2006-01-26 17:04 EST by Jan-Patrick Perisse
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-27 15:18:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan-Patrick Perisse 2006-01-26 17:04:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When an interface is configured with ifup, the virtual interfaces attached to it (ethx:n) are also loaded despite they have ONBOOT=no configured.
This is caused by ifup-aliase NOT looking for the ONBOOT parameter.
It can be corrected by adding:
 if [ "${ONBOOT}" = "no" -o "${ONBOOT}" = "NO" ];  then
              exit 0
on the new_interface() function.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.ifup eth0

Actual Results:  eth0 and eth0:1 are up

Expected Results:  Only eth0 should be up (eth0:1 should also be up IF is says ONBOOT=yes, otherwise ifup eth0:1 should specified to bring up the interface)

Additional info:
Comment 1 Bill Nottingham 2006-01-27 15:18:55 EST

*** This bug has been marked as a duplicate of 155497 ***

Note You need to log in before you can comment on or make changes to this bug.