Bug 1790668 - libudisks2-devel not available in repos
Summary: libudisks2-devel not available in repos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: udisks2
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Tomáš Bžatek
QA Contact: guazhang@redhat.com
URL:
Whiteboard:
Depends On: 1792443 1792446 1792447 1792448
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-13 21:11 UTC by Dakota Williams
Modified: 2021-09-06 15:32 UTC (History)
7 users (show)

Fixed In Version: udisks2-2.9.0-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 03:33:54 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:4749 0 None None None 2020-11-04 03:34:02 UTC

Description Dakota Williams 2020-01-13 21:11:16 UTC
Description of problem:

libudisks2 is an available package, however development headers for the library are not available in codeready-builder-for-rhel-8-x86_64-rpms. 

Version-Release number of selected component (if applicable):

2.8.3-2

How reproducible:

Every time

Steps to Reproduce:

1. subscription-manager repo --enable codeready-builder-for-rhel-8-x86_64-rpms
2. dnf install libudisks2-devel

Actual results:

Updating Subscription Management repositories.
Extra Packages for Enterprise Linux Modular 8 - 121 kB/s |  17 kB     00:00    
Extra Packages for Enterprise Linux 8 - x86_64  6.8 kB/s |  19 kB     00:02    
Red Hat Enterprise Linux 8 for x86_64 - AppStre  17 kB/s | 4.5 kB     00:00    
Red Hat CodeReady Linux Builder for RHEL 8 x86_  18 kB/s | 4.5 kB     00:00    
Red Hat Enterprise Linux 8 for x86_64 - Supplem  15 kB/s | 3.8 kB     00:00    
Red Hat Enterprise Linux 8 for x86_64 - BaseOS   16 kB/s | 4.1 kB     00:00    
No match for argument: libudisks2-devel

Expected results:

libudisks2-devel is installed

Additional info:

Comment 1 Tomáš Bžatek 2020-01-14 16:00:18 UTC
While I cannot speak for Red Hat Product Management, I can only say this is on purpose. We don't ship all -devel packages by default. Please contact your support representative for clarification.

Would you mind sharing your specific use case please? As a side question and out of curiosity from the upstream udisks maintainer point of view, we'd be interested to learn more about projects that build on top of UDisks and the way it is used.

Comment 2 Dakota Williams 2020-01-14 20:25:09 UTC
Sure, I work on a product which uses udisks2 for its block device enumeration. The library it provides is helpful as much as the module system will be for future development.

Comment 13 guazhang@redhat.com 2020-06-24 06:24:12 UTC
Hello


# yum list | grep libudisks2-devel
Failed to set locale, defaulting to C.UTF-8
libudisks2-devel.x86_64                                                                                                                                                                                            2.9.0-1.el8                                       @beaker-CRB                      
libudisks2-devel.i686                                                                                                                                                                                              2.9.0-1.el8                                       beaker-CRB                       

the package have been added to repo, so move to verified

Comment 16 errata-xmlrpc 2020-11-04 03:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (udisks2 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:4749


Note You need to log in before you can comment on or make changes to this bug.