Bug 179067 - Kernel compile error
Kernel compile error
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 17:19 EST by Michael Orr
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 16:20:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Orr 2006-01-26 17:19:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
'make xxxconfig' (xconfig, menuconfig, oldconfig) all work OK.  'make rpm' or 'make bzImage' dies with the following error:

make[1]: *** No rule to make target `init/main.o', needed by `init/built-in.o'.  Stop.
make: *** [init] Error 2

I have done 'make mrproper' and 'make distclean'.  I have copied /boot/ config-2.6.14-1.1656_FC4 as .config without modification.  These do not resolve the problem.

Version-Release number of selected component (if applicable):
kernel-2.6.141.1656_FC4

How reproducible:
Always

Steps to Reproduce:
1. make menuconfig
2. make bzImage
3.
  

Actual Results:  make bzImage
  CHK     include/linux/version.h
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/split-include
  HOSTCC  scripts/basic/docproc
  SPLIT   include/linux/autoconf.h -> include/config/*
  HOSTCC  scripts/genksyms/genksyms.o
  HOSTCC  scripts/genksyms/lex.o
scripts/genksyms/lex.c:546:5: warning: "YY_STACK_USED" is not defined
scripts/genksyms/lex.c:1424:5: warning: "YY_ALWAYS_INTERACTIVE" is not defined
scripts/genksyms/lex.c:1427:5: warning: "YY_NEVER_INTERACTIVE" is not defined
scripts/genksyms/lex.c:1718:5: warning: "YY_MAIN" is not defined
  HOSTCC  scripts/genksyms/parse.o
/usr/lib/bison.simple:164:5: warning: "YYMAXDEPTH" is not defined
  HOSTLD  scripts/genksyms/genksyms
  CC      scripts/mod/empty.o
  HOSTCC  scripts/mod/mk_elfconfig
  MKELF   scripts/mod/elfconfig.h
  HOSTCC  scripts/mod/file2alias.o
  HOSTCC  scripts/mod/modpost.o
  HOSTCC  scripts/mod/sumversion.o
  HOSTLD  scripts/mod/modpost
  HOSTCC  scripts/kallsyms
  HOSTCC  scripts/pnmtologo
  HOSTCC  scripts/conmakehash
make[1]: *** No rule to make target `init/main.o', needed by `init/built-in.o'.  Stop.
make: *** [init] Error 2


Expected Results:  Successful compilation.


Additional info:
Comment 1 Dave Jones 2006-01-27 16:20:12 EST
looks like you're not building from the src.rpm, but the -devel package.


*** This bug has been marked as a duplicate of 126342 ***
Comment 2 Michael Orr 2006-01-30 10:08:17 EST
(In reply to comment #1)
> looks like you're not building from the src.rpm, but the -devel package.
> 
> 
> *** This bug has been marked as a duplicate of 126342 ***

According to the Fedora 4 Release Notes
(http://fedora.redhat.com/docs/release-notes/fc4/errata/#sn-kernel):

7.2.2.2. Kernel Flavors

Fedora Core includes the following kernel builds:

    *

      Native kernel, in both uniprocessor and SMP varieties.

      Configured sources are available in the kernel-devel-<version>.<arch>.rpm
package.
    *

      Virtual kernel for use with the Xen emulator package.

      Configured sources are available in the
kernel-xen0-devel-<version>.<arch>.rpm package.

Sources for both kernel flavors may be installed at the same time. The files
will be installed into the /usr/src/kernels/<version>[-xen0]-<arch>/ tree. Use
the command:

rpm -Uvh kernel-devel[-xen0]-<version>.<arch>.rpm

Note You need to log in before you can comment on or make changes to this bug.