Bug 1790757 - Should not create secret if idp is not created successfully
Summary: Should not create secret if idp is not created successfully
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1790863 (view as bug list)
Depends On:
Blocks: 1790863
TreeView+ depends on / blocked
 
Reported: 2020-01-14 05:57 UTC by Yanping Zhang
Modified: 2020-05-04 11:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1790863 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:24:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3947 None closed Bug 1790757: Fix input type for inputs that hold URL in cluster-setting forms 2020-02-25 07:52:45 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:24:32 UTC

Description Yanping Zhang 2020-01-14 05:57:57 UTC
Description of problem:
When do negative test for idp, the idp is not created successfully but secret is already created.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2020-01-11-070223

How reproducible:
Always

Steps to Reproduce:
1.Create gitlab idp from console, set name, client id, client secret, and input "testurl" in field "URL", click "Add".
2.Check secret in openshift-config project.
3.

Actual results:
1. It will prompt error: "must contain a scheme (e.g. https://)" for field "spec.identityProviders[1].gitlab.url"."
2. New secret prefix with "gitlab-client-secret" is listed in openshift-config project.

Expected results:
2. Should not create secret if idp is not created successfully.


Additional info:

Comment 2 Yanping Zhang 2020-01-19 06:38:38 UTC
Tested on OCP 4.3 with payload 4.4.0-0.nightly-2020-01-18-223038, tried to create gitlab idp with some field invalid, after creation failed, checked secret under openshift-config project, no new secret was created.
The bug is fixed, so move it to Verified.

Comment 3 Jakub Hadvig 2020-01-23 12:07:25 UTC
*** Bug 1790863 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-05-04 11:24:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.