Bug 1790759 (CVE-2020-1694) - CVE-2020-1694 keycloak: verify-token-audience support is missing in the NodeJS adapter
Summary: CVE-2020-1694 keycloak: verify-token-audience support is missing in the NodeJ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2020-1694
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1786329
TreeView+ depends on / blocked
 
Reported: 2020-01-14 06:13 UTC by Paramvir jindal
Modified: 2020-07-09 15:50 UTC (History)
32 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Keycloak, where the NodeJS adapter did not support the verify-token-audience. This flaw results in some users having access to sensitive information outside of their permissions.
Clone Of:
Environment:
Last Closed: 2020-07-02 13:27:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:2813 None None None 2020-07-02 13:21:26 UTC

Description Paramvir jindal 2020-01-14 06:13:25 UTC
Bug URL: https://issues.jboss.org/browse/KEYCLOAK-10389

In order to be aligned with the other adapters, the NodeJS Adapter should also support the "verify-token-audience" configuration parameter.

Comment 6 errata-xmlrpc 2020-07-02 13:21:24 UTC
This issue has been addressed in the following products:

  Red Hat Single Sign-On 7.4.1

Via RHSA-2020:2813 https://access.redhat.com/errata/RHSA-2020:2813

Comment 7 Product Security DevOps Team 2020-07-02 13:27:43 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-1694


Note You need to log in before you can comment on or make changes to this bug.