Bug 179085 - ImportError: No module named output
Summary: ImportError: No module named output
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-27 05:47 UTC by John Ellson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 07:28:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2006-01-27 05:47:53 UTC
Description of problem:
Latest yumex dies with:
ImportError: No module named output

Reverting to yumex-0.45-2.0.fc5.noarch.rpm eliminates the problem.

Version-Release number of selected component (if applicable):
yumex-0.99.2-1.0.fc5.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1.yumex
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 35, in ?
    from yumex import *
  File "/usr/lib/python2.4/site-packages/yumex/__init__.py", line 24, in ?
    from yumexBase import *
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 47, in ?
    import output
ImportError: No module named output


Expected results:


Additional info:

Comment 1 Tim Lauridsen 2006-01-27 07:28:10 UTC
The Error happens because on my development workstation im testing against a yum
cvs checkout, located in /usr/share/yum-cvs, so i add this path to the Python
Path , so the output module is loaded from this directory. On a normal yum
installation yum is located in /usr/share/yum-cli so this path has to be include
in the Python Path. I forgot to change this before packing the code for the
Fedora Extras buildsystem. I have made a new release 0.99.3 there fixes the
problem. I has build  on the buildsystem, yesterday evening (CET). So i will
popup to day in there repositories.



Note You need to log in before you can comment on or make changes to this bug.