Bug 1790954 - `oc --v 7` shows User-Agent as "v0.0.0...$Format"
Summary: `oc --v 7` shows User-Agent as "v0.0.0...$Format"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.3.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard: LifecycleReset
Depends On: 1779519
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-14 15:23 UTC by Maciej Szulik
Modified: 2020-08-31 10:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1779519
Environment:
Last Closed: 2020-08-25 06:28:37 UTC
Target Upstream Version:
maszulik: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 255 None closed Bug 1790954: fix version ldflags 2020-08-31 10:27:30 UTC

Description Maciej Szulik 2020-01-14 15:23:05 UTC
+++ This bug was initially created as a clone of Bug #1779519 +++

Description of problem:
4.x `oc --v 7` shows User-Agent as "v0.0.0...$Format", while upstream-downloaded kubectl and 3.11 oc show concrete version and commit:
oc get po --v 7
I1204 14:08:48.610751   26500 loader.go:375] Config loaded from file:  /home/xxia/my/env/xxia-1204-1.cfg
I1204 14:08:48.633673   26500 round_trippers.go:420] GET https://...:6443/api/v1/namespaces/default/pods?limit=500
I1204 14:08:48.633941   26500 round_trippers.go:427] Request Headers:
I1204 14:08:48.634130   26500 round_trippers.go:431]     Accept: application/json;as=Table;v=v1beta1;g=meta.k8s.io, application/json
I1204 14:08:48.634332   26500 round_trippers.go:431]     User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format

kubernetes/client/bin/kubectl get po --v 7
I1204 14:08:24.252447   26493 loader.go:375] Config loaded from file:  /home/xxia/my/env/xxia-1204-1.cfg
I1204 14:08:24.292663   26493 round_trippers.go:420] GET https://...:6443/api?timeout=32s
I1204 14:08:24.292944   26493 round_trippers.go:427] Request Headers:
I1204 14:08:24.293196   26493 round_trippers.go:431]     Accept: application/json, */*
I1204 14:08:24.293433   26493 round_trippers.go:431]     User-Agent: kubectl/v1.17.0 (linux/amd64) kubernetes/97c7ccc

3.11/oc whoami --loglevel 7
I1204 14:07:32.972676   26468 loader.go:359] Config loaded from file /home/xxia/my/env/xxia-1204-1.cfg
I1204 14:07:32.973985   26468 loader.go:359] Config loaded from file /home/xxia/my/env/xxia-1204-1.cfg
I1204 14:07:32.974893   26468 round_trippers.go:383] GET https://...:6443/apis/user.openshift.io/v1/users/~
I1204 14:07:32.975082   26468 round_trippers.go:390] Request Headers:
I1204 14:07:32.975329   26468 round_trippers.go:393]     Accept: application/json, */*
I1204 14:07:32.975518   26468 round_trippers.go:393]     User-Agent: oc/v1.11.0+d4cacc0 (linux/amd64) kubernetes/d4cacc0

Version-Release number of selected component (if applicable):
rpm -qa | grep openshift-clients
openshift-clients-4.3.0-201912030917.git.1.c68c4bf.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
See above Desc

Actual results:
See above Desc

Expected results:
Should show concrete version and commit

--- Additional comment from Maciej Szulik on 2019-12-04 21:19:17 CET ---

It looks like it broke when we switched to separate repository, but it's not a critical issue that would block 4.3, although it should be backported all the way back to 4.2, since that's when it is broken too.

Comment 3 zhou ying 2020-04-08 04:33:31 UTC
Still could reproduce the issue with oc from yum repo and payload:

[root@dhcp-140-138 ~]# oc version -o yaml 
clientVersion:
  buildDate: "2020-04-04T06:05:10Z"
  compiler: gc
  gitCommit: 081196cac40a01e541152175cc4da92d3a5ab07d
  gitTreeState: clean
  gitVersion: 4.3.11-202004040552-081196c
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64

[root@dhcp-140-138 ~]# oc get po -v 7
I0408 12:25:07.134096    4507 loader.go:375] Config loaded from file:  /root/kubeconfig
I0408 12:25:07.135628    4507 round_trippers.go:420] GET https://api.yinzhou-bugv.qe.devcluster.openshift.com:6443/apis/metrics.k8s.io/v1beta1?timeout=32s
I0408 12:25:07.135643    4507 round_trippers.go:427] Request Headers:
I0408 12:25:07.135655    4507 round_trippers.go:431]     Accept: application/json, */*
I0408 12:25:07.135665    4507 round_trippers.go:431]     User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format


[root@dhcp-140-138 ~]# ./oc version -o yaml 
clientVersion:
  buildDate: "2020-04-06T13:26:27Z"
  compiler: gc
  gitCommit: 081196cac40a01e541152175cc4da92d3a5ab07d
  gitTreeState: dirty
  gitVersion: openshift-clients-4.3.11-202004040552
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64


[root@dhcp-140-138 ~]# ./oc get po -v 7
I0408 12:31:04.264509    4562 loader.go:375] Config loaded from file:  /root/kubeconfig
I0408 12:31:04.266024    4562 round_trippers.go:420] GET https://api.yinzhou-bugv.qe.devcluster.openshift.com:6443/apis/metrics.k8s.io/v1beta1?timeout=32s
I0408 12:31:04.266038    4562 round_trippers.go:427] Request Headers:
I0408 12:31:04.266052    4562 round_trippers.go:431]     Accept: application/json, */*
I0408 12:31:04.266063    4562 round_trippers.go:431]     User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format

Comment 5 Maciej Szulik 2020-05-20 09:37:34 UTC
I've verified this with quay.io/openshift-release-dev/ocp-release:4.3.21-x86_64 and this works as expected, moving to qa.

Comment 9 zhou ying 2020-05-25 05:27:28 UTC
Still could reproduce :
[root@dhcp-140-138 ~]#  oc version -o yaml
clientVersion:
  buildDate: "2020-05-23T09:59:41Z"
  compiler: gc
  gitCommit: 4fb2d4d96e6b604f7d4ee49080238a5aec04dc4f
  gitTreeState: clean
  gitVersion: 4.3.23-202005230952-4fb2d4d
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64

[root@dhcp-140-138 ~]# oc get po --v 7
I0525 13:25:33.097361   23152 loader.go:375] Config loaded from file:  /root/kubeconfig
I0525 13:25:33.098842   23152 round_trippers.go:420] GET https://api.xxxxx.openshift.com:6443/apis/metrics.k8s.io/v1beta1?timeout=32s
I0525 13:25:33.098856   23152 round_trippers.go:427] Request Headers:
I0525 13:25:33.098872   23152 round_trippers.go:431]     User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format
I0525 13:25:33.098885   23152 round_trippers.go:431]     Accept: application/json, */*


[root@dhcp-140-138 ~]# ./oc version -o yaml
clientVersion:
  buildDate: "2020-05-23T10:59:39Z"
  compiler: gc
  gitCommit: 4fb2d4d96e6b604f7d4ee49080238a5aec04dc4f
  gitTreeState: dirty
  gitVersion: openshift-clients-4.3.23-202005230952
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.5.0-0.nightly-2020-05-24-223848
releaseClientVersion: 4.3.0-0.nightly-2020-05-24-223407


[root@dhcp-140-138 ~]# ./oc get po --v 7
I0525 13:26:29.213673   23177 loader.go:375] Config loaded from file:  /root/kubeconfig
I0525 13:26:29.215020   23177 round_trippers.go:420] GET https://apixxxxx.openshift.com:6443/apis/metrics.k8s.io/v1beta1?timeout=32s
I0525 13:26:29.215035   23177 round_trippers.go:427] Request Headers:
I0525 13:26:29.215044   23177 round_trippers.go:431]     Accept: application/json, */*
I0525 13:26:29.215051   23177 round_trippers.go:431]     User-Agent: oc/v0.0.0 (linux/amd64) kubernetes/$Format

Comment 10 Maciej Szulik 2020-05-25 11:14:00 UTC
Where did you get the binary from?

Comment 12 zhou ying 2020-06-01 01:44:48 UTC
oc installed from yum repo or extracted from payload: oc adm release extract --command='oc'   registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-05-30-012900

[root@dhcp-140-138 ~]# ./oc version -o yaml 
clientVersion:
  buildDate: "2020-05-25T09:06:07Z"
  compiler: gc
  gitCommit: 4fb2d4d96e6b604f7d4ee49080238a5aec04dc4f
  gitTreeState: dirty
  gitVersion: openshift-clients-4.3.23-202005230952
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64
releaseClientVersion: 4.3.0-0.nightly-2020-05-30-012900

Comment 13 Maciej Szulik 2020-06-18 09:45:46 UTC
Iā€™m adding UpcomingSprint, because I was occupied by fixing bugs with higher priority/severity, developing new features with higher priority, or developing new features to improve stability at a macro level. I will revisit this bug next sprint.

Comment 14 Michal Fojtik 2020-08-25 06:28:37 UTC
This bug hasn't had any activity 7 days after it was marked as LifecycleStale, so we are closing this bug as WONTFIX. If you consider this bug still valuable, please reopen it or create new bug.

Comment 15 Michal Fojtik 2020-08-25 06:28:44 UTC
The LifecycleStale keyword was removed because the bug got commented on recently.
The bug assignee was notified.


Note You need to log in before you can comment on or make changes to this bug.