Bug 1790998 - Metric labels set incorrectly during build
Summary: Metric labels set incorrectly during build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Stefan Schimanski
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-14 16:36 UTC by Pawel Krupa
Modified: 2020-05-04 11:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:24:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oauth-server pull 31 None closed Bug 1790998: switch version metric to component-base 2020-04-08 10:06:10 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:24:40 UTC

Description Pawel Krupa 2020-01-14 16:36:25 UTC
Description of problem:
Following metric labels are not set: `gitCommit` and `gitVersion`. They are returned as `gitCommit="$Format:%H$",gitVersion="v0.0.0-master+$Format:%h$"`

This is the case for oauth-openshift service

Version-Release number of selected component (if applicable):
4.4.0

How reproducible:
Always

Steps to Reproduce:
1. Start a cluster
2. Go to metrics console
3. search for `kubernetes_build_info{job!~"kube-dns|coredns",gitVersion!="v1.17.0"}`

Actual results:
Prometheus returns metrics with invalid label values:
`gitCommit="$Format:%H$" and gitVersion="v0.0.0-master+$Format:%h$"`

Expected results:
Nothing is returned

Additional info:
Frequently happens in CI builds.

Comment 8 errata-xmlrpc 2020-05-04 11:24:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.