Bug 1791147 - [virtio-win][vioscsi] Hit BSOD(d1) when run whql job "Bus Reset Test" with virtio-win-prewhql-176 vioscsi driver
Summary: [virtio-win][vioscsi] Hit BSOD(d1) when run whql job "Bus Reset Test" with vi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Vadim Rozenfeld
QA Contact: Peixiu Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-15 01:46 UTC by Peixiu Hou
Modified: 2020-04-28 16:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:16 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:05:30 UTC

Description Peixiu Hou 2020-01-15 01:46:28 UTC
Description of problem:
with virtio-win-prewhql-176 scsi driver, whql job "Bus Reset Test" failed as BSOD(D1)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.boot 2 vms up with follows commands:
1). VM1:
screen /usr/libexec/qemu-kvm -name 176SCS12R235Q0D -enable-kvm -m 6G -smp 8 -uuid c1047f8b-8f03-496d-878f-62dd012ac800 -nodefaults -cpu Skylake-Server,hv_stimer,hv_synic,hv_time,hv_relaxed,hv_vpindex,hv_spinlocks=0xfff,hv_vapic,hv_reset,hv-tlbflush -chardev socket,id=charmonitor,path=/tmp/176SCS12R235Q0D,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb -blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=176SCS12R235Q0D,node-name=my_file -blockdev driver=raw,node-name=my,file=my_file -device ide-hd,drive=my,id=ide0-0-0,bus=ide.0,unit=0 -blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/kvm_autotest_root/iso/ISO/Win2012R2/en_windows_server_2012_r2_with_update_x64_dvd_6052708.iso,node-name=my_cd,read-only=on -blockdev driver=raw,node-name=mycd,file=my_cd,read-only=on -device ide-cd,drive=mycd,id=ide0-1-0,bus=ide.1,unit=0 -blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=176SCS12R235Q0D.iso,node-name=my_iso,read-only=on -blockdev driver=raw,node-name=myiso,file=my_iso,read-only=on -device ide-cd,drive=myiso,id=ide0-1-1 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:58:68:12:d4 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga std -M q35 -device pcie-root-port,bus=pcie.0,id=root1.0,slot=1 -device virtio-scsi-pci,id=scsi0,bus=root1.0,num_queues=8 \
-blockdev driver=iscsi,transport=tcp,cache.direct=off,cache.no-flush=on,portal=10.73.224.131:3260,target=iqn.2019-01.local.server:sas,lun=0,node-name=my_scsi -blockdev driver=raw,node-name=myscsi,file=my_scsi -device scsi-block,bus=scsi0.0,drive=myscsi,id=scsi-disk0

VM2:
screen /usr/libexec/qemu-kvm -name 176SCS12R235RRY -enable-kvm -m 6G -smp 8 -uuid 24b74ffc-749d-4773-83a6-8816c7720904 -nodefaults -cpu Skylake-Server,hv_stimer,hv_synic,hv_time,hv_relaxed,hv_vpindex,hv_spinlocks=0xfff,hv_vapic,hv_reset,hv-tlbflush -chardev socket,id=charmonitor,path=/tmp/176SCS12R235RRY,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb -blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=176SCS12R235RRY,node-name=my_file -blockdev driver=raw,node-name=my,file=my_file -device ide-hd,drive=my,id=ide0-0-0,bus=ide.0,unit=0 -blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/kvm_autotest_root/iso/ISO/Win2012R2/en_windows_server_2012_r2_with_update_x64_dvd_6052708.iso,node-name=my_cd,read-only=on -blockdev driver=raw,node-name=mycd,file=my_cd,read-only=on -device ide-cd,drive=mycd,id=ide0-1-0,bus=ide.1,unit=0 -blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=176SCS12R235RRY.iso,node-name=my_iso,read-only=on -blockdev driver=raw,node-name=myiso,file=my_iso,read-only=on -device ide-cd,drive=myiso,id=ide0-1-1 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:53:39:18:e1 -device usb-tablet,id=input0 -vnc 0.0.0.0:4 -vga std -M q35 -device pcie-root-port,bus=pcie.0,id=root1.0,slot=1 -device virtio-scsi-pci,id=scsi0,bus=root1.0,num_queues=8 \
-blockdev driver=iscsi,transport=tcp,cache.direct=off,cache.no-flush=on,portal=10.73.224.131:3260,target=iqn.2019-01.local.server:sas,lun=0,node-name=my_scsi -blockdev driver=raw,node-name=myscsi,file=my_scsi -device scsi-block,bus=scsi0.0,drive=myscsi,id=scsi-disk0

2. Submit the job "Bus Reset Test" from HCK studio.
3. Check the vm status.

Actual results:
BSOD

Expected results:
Passed

Additional info:
1. Tried test with virtio-win-prewhql-160 build, cannot reproduce this issue.
So it's a regression issue.

Comment 3 Vadim Rozenfeld 2020-01-22 03:06:26 UTC
Can you please give a try to the new drivers?

https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1063846

Thanks,
Vadim.

Comment 4 Peixiu Hou 2020-01-22 06:10:13 UTC
(In reply to Vadim Rozenfeld from comment #3)
> Can you please give a try to the new drivers?
> 
> https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1063846
> 

Sure, I tested with new driver virtio-win-prewhql-178, cannot reproduce this bug, the job can be passed successfully~
The bug has been fixed, thanks a lot~

Best Regards~
Peixiu

> Thanks,
> Vadim.

Comment 5 Vadim Rozenfeld 2020-01-22 06:23:48 UTC
(In reply to Peixiu Hou from comment #4)
> (In reply to Vadim Rozenfeld from comment #3)
> > Can you please give a try to the new drivers?
> > 
> > https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1063846
> > 
> 
> Sure, I tested with new driver virtio-win-prewhql-178, cannot reproduce this
> bug, the job can be passed successfully~
> The bug has been fixed, thanks a lot~
> 
> Best Regards~
> Peixiu
> 
> > Thanks,
> > Vadim.

Thanks a lot, Peixiu.
Vadim.

Comment 11 errata-xmlrpc 2020-04-28 16:05:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757


Note You need to log in before you can comment on or make changes to this bug.