Bug 1791182 - Add stable-4.3, fast-4.3, and candidate-4.3 channels to UI in 4.2.z
Summary: Add stable-4.3, fast-4.3, and candidate-4.3 channels to UI in 4.2.z
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-15 07:14 UTC by Yadan Pei
Modified: 2020-01-22 10:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-22 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0107 0 None None None 2020-01-22 10:46:57 UTC

Description Yadan Pei 2020-01-15 07:14:34 UTC
Description of problem:
Since OCP 4.3 is going to be released soon, we need to add *-4.3 channels so that OCP 4.2 customer can upgrade to OCP 4.3 from UI.

Version-Release number of selected component (if applicable):
4.2.14

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yadan Pei 2020-01-15 07:15:41 UTC
Channels should be added are: stable-4.3, fast-4.3, candidate-4.3 Let me know if I'm wrong

Comment 4 Yadan Pei 2020-01-19 03:25:27 UTC
1. Setup a cluster with quay.io/openshift-release-dev/ocp-release:4.2.16-x86_64
2. Patch upstream to make https://openshift-release.svc.ci.openshift.org/ as update server
$ oc patch clusterversion/version --patch '{"spec":{"upstream":"https://openshift-release.svc.ci.openshift.org/graph"}}' --type=merge
3. admin user login to console, check upgrade channel in Adminitration -> Cluster Settings -> Channel, we can see stable-4.3, fast-4.3, candidate-4.3 in the list


Verified on 4.2.16

Comment 6 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107


Note You need to log in before you can comment on or make changes to this bug.