Bug 1791200 - Lack of configured alertmanager routes should be surfaced as an alert
Summary: Lack of configured alertmanager routes should be surfaced as an alert
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1791198
Blocks: 1791211
TreeView+ depends on / blocked
 
Reported: 2020-01-15 08:35 UTC by Pawel Krupa
Modified: 2020-03-10 23:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1791198
: 1791211 (view as bug list)
Environment:
Last Closed: 2020-03-10 23:52:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 613 None closed Bug 1791200: Add alert for no routes configured in alertmanager 2020-04-27 10:15:18 UTC
Github openshift origin pull 24465 None closed Bug 1791200: test/extended/prometheus: exclude AlertmanagerReceiversNotConfigured from checking 2020-04-27 10:15:18 UTC
Red Hat Product Errata RHBA-2020:0676 None None None 2020-03-10 23:53:17 UTC

Description Pawel Krupa 2020-01-15 08:35:05 UTC
+++ This bug was initially created as a clone of Bug #1791198 +++

Description of problem:
Prometheus should fire an alert when there is no routes configured in alertmanager


Version-Release number of selected component (if applicable):
4.2

How reproducible:
always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Based on https://coreos.slack.com/archives/C0VMT03S5/p1575909697091600 and https://github.com/openshift/cluster-monitoring-operator/pull/554#issuecomment-561922011

BZ made for backporting purposes

Comment 5 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676


Note You need to log in before you can comment on or make changes to this bug.