Bug 179124 - anaconda should add 3 button mouse emulation by default for powerpc
anaconda should add 3 button mouse emulation by default for powerpc
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 11:01 EST by Richard Hughes
Modified: 2013-01-09 22:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 16:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal of my iBook (55.50 KB, text/plain)
2006-02-18 19:04 EST, Richard Hughes
no flags Details
output of /proc/bus/input/devices (818 bytes, text/plain)
2006-03-06 14:22 EST, Richard Hughes
no flags Details

  None (edit)
Description Richard Hughes 2006-01-27 11:01:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Apple iBooks only have one mouse button. Fedora is pretty unusable without a right mouse button.

In /etc/sysctl.conf I have added the following:

# Emulates a 3 button mouse for apple hardware
# Fn&Alt = Left Button, Fn&Apple = Middle Button
dev.mac_hid.mouse_button_emulation = 1

Which also works when I plug in my PC mouse with three mouse buttons.

This should work by default in my opinion.

Apologies if the component isn't anaconda, but I guessed it's an install thing.


Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. Install fedora core rawhide
2. Try to unmount a usbkey without using the right mouse button
3. Add stuff to sysctl.conf to make fedora useable.
  

Actual Results:  I have to manually edit sysctl.conf

Expected Results:  This stuff should be added to sysctl.conf automatically

Additional info:
Comment 1 Jeremy Katz 2006-01-28 00:48:24 EST
If this is the "right" thing, then it should just be set up by default. 
anaconda is not in the business of having a list of "if crap hardware A, do
workaround.  for crap hardware B, do different workaround" :-)
Comment 2 Bill Nottingham 2006-01-30 13:26:45 EST
Make a udev rule that runs on the input device add of 'Apple Mouse Thingy' (or
whatever it is.) :)
Comment 3 Richard Hughes 2006-01-31 04:20:28 EST
How would the udev event trigger a stuff to be added to a file if not already
present? Could this be added in a different way to kudzu?
Comment 4 Bill Nottingham 2006-01-31 11:16:21 EST
kudzu doesn't do anything.

The udev rule doesn't need to edit /etc/sysctl.conf... it can just set the key
itself.
Comment 5 Harald Hoyer 2006-02-15 07:13:50 EST
err, and how should the rule look like? I don't have any iBook here...
Comment 6 Bill Nottingham 2006-02-15 11:35:45 EST
Don't know for sure. Probably something like:

ACTION=="add", SUBSYSTEM=="input", <some sysfs gunk that matches apple here>,
RUN+="/sbin/sysctl -w dev.mac_hid.mouse_button_emulation=1"

CC'ing some PPC people.
Comment 8 Richard Hughes 2006-02-18 19:04:10 EST
Created attachment 124856 [details]
lshal of my iBook

Here's my lshal from CVS hal. See if you can find anything to match against,
because I can't see any input devices.
Comment 9 Richard Hughes 2006-03-06 13:50:38 EST
Is there anything more I can provide? Thanks.
Comment 10 Paul Nasrat 2006-03-06 13:52:39 EST
output of /proc/bus/input/devices
Comment 11 Richard Hughes 2006-03-06 14:22:03 EST
Created attachment 125716 [details]
output of /proc/bus/input/devices

Attached. Many thanks.
Comment 12 Richard Hughes 2006-03-11 16:16:44 EST
Now that FC5 is back a few days, could this make it into the release? My iBook
has no way to unmount a usb pendrive without a right mouse button.
Comment 13 David Lawrence 2006-04-18 16:31:53 EDT
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.
Comment 14 Harald Hoyer 2007-06-26 08:54:02 EDT
I would like to see that in HAL... No way, I will add 1000 rules for every mouse
combination.
Comment 15 David Zeuthen 2007-06-26 11:23:14 EDT
Back to Anaconda...
Comment 16 David Zeuthen 2007-06-26 11:38:13 EDT
Changing hardware to All as this all affects Macbook and Macbook Pro on x86/x86_64.
Comment 17 Jeremy Katz 2007-06-26 17:49:41 EDT
anaconda still isn't the right place for this... do we really care outside of X?
Comment 18 David Cantrell 2007-08-22 16:05:43 EDT
Closing per comment #17.  Anaconda isn't the right place to fix this problem (if
it is a problem).  No other component wants to claim it, so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.