Bug 179129 - gnucash fails after splash screen
Summary: gnucash fails after splash screen
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-27 16:17 UTC by Neal Lundgaard
Modified: 2014-03-17 02:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 19:39:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
slightly modified xfs script (4.07 KB, text/plain)
2006-01-31 17:06 UTC, Bill Nottingham
no flags Details

Description Neal Lundgaard 2006-01-27 16:17:47 UTC
Description of problem:
Staring gnucash in gnome dies after splash screen. staring from consol reports:
Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback font:
-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*


Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1.In Gnome open consol
2.execute gnucash command
3.Read resuls from consol screen :-)
  
Actual results:


Expected results:


Additional info:

Comment 1 Bill Nottingham 2006-01-27 18:28:16 UTC
Stock test2 upgrade, or did it start at test1 and then get upgraded?

Comment 2 Neal Lundgaard 2006-01-27 19:20:49 UTC
Sorry, my 1st bugzilla report.
Fresh install from the internet.
I did not have FC5 installed prior to t2.
I run the updater daily. Current to (1-27-06)
Has failed since my initial install
which was about 2 days after the t2 release.
I am not aware of any t2 update causing this.

Comment 3 Bill Nottingham 2006-01-30 18:25:43 UTC
What happens if you, as root, run:

chkfontpath --list | grep /usr | awk -F ':' '{ print $2 }'| while read foo ; do
    rm -f $foo/fonts.{dir,scale}
done
service xfs restart

and then restart your X server?


Comment 4 John Shepard 2006-01-31 16:33:38 UTC
I'm getting the exact same problem, so I followed the steps in Comment #3 and got

Failed to start the X server (your graphical
interface). It is likely that it is not set
up correctly. Would you like to view the X
server ouptut to diagnose the problem?


Executing
mkfontscale .
mkfontdir .
in the /usr/share/X11/fonts/misc dir allows the X server to start again.

It looks like these commands are in the xfs script - but did not get called.

fc5t2 is up to date as of 1/31/06

Here is some additional information

[root@localhost ~]# chkfontpath --list
Current directories in font path:
1: /usr/share/X11/fonts/misc:unscaled
2: /usr/share/X11/fonts/75dpi:unscaled
3: /usr/share/X11/fonts/100dpi:unscaled
4: /usr/share/X11/fonts/Type1
5: /usr/share/fonts/default/Type1
6:
[root@localhost ~]# ls -l /usr/share/X11/fonts/
total 28
drwxr-xr-x 3 root root 4096 Jan 29 17:04 encodings
drwxr-xr-x 2 root root 8192 Jan 31 10:39 misc
drwxr-xr-x 2 root root 4096 Jan 29 17:00 util

gnucash still generates the same message

Comment 5 Bill Nottingham 2006-01-31 17:06:52 UTC
Created attachment 123921 [details]
slightly modified xfs script

Does this xfs script make things better?

Comment 6 John Shepard 2006-01-31 17:45:17 UTC
X did come back up on its on this time, but gnucash still dies with the same
message.

Comment 7 Bill Nottingham 2006-01-31 17:51:02 UTC
Hm,ok. What font packages do you have installed?

Comment 8 John Shepard 2006-01-31 18:32:03 UTC
[root@localhost ~]# rpm -qa | grep -i font
ghostscript-fonts-5.50-13.1
bitmap-fonts-0.3-5.1
fontconfig-2.3.93.cvs20060124-1
tetex-fonts-3.0-16
libfontenc-1.0.1-1
xorg-x11-fonts-base-7.0-1
bitstream-vera-fonts-1.10-5.1
chkfontpath-1.10.0-4.1
libXfont-1.0.0-2
libXfontcache-1.0.1-1
urw-fonts-2.3-6.1
xorg-x11-font-utils-1.0.1-1


Comment 9 Bill Nottingham 2006-01-31 18:59:14 UTC
Ah, ok.

I suspect installing  xorg-x11-fonts-75dpi fixes it?

Comment 10 Bill Nottingham 2006-01-31 19:39:44 UTC
Make that xorg-x11-fonts-ISO8859-1-75dpi.

This has been fixed in the comps file, so installs of test3 or FC5 final should
have this taken care of.

Comment 11 John Shepard 2006-01-31 20:31:22 UTC
xorg-x11-fonts-75dpi allowed gnucash to start, but with empty boxes for letters.
xorg-x11-fonts-ISO8859-1-75dpi worked!


Note You need to log in before you can comment on or make changes to this bug.