Bug 1791336 - [IPv6] Connection refused to fluentd metrics
Summary: [IPv6] Connection refused to fluentd metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1794382
TreeView+ depends on / blocked
 
Reported: 2020-01-15 15:03 UTC by Anping Li
Modified: 2020-05-04 11:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1794382 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:24:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 333 0 None closed Bug 1791336: Fix fluent metrics config to support ipv6 2021-02-02 19:32:37 UTC
Github openshift cluster-logging-operator pull 345 0 None closed Bug 1791336: Fix fluent conf for metrics on ipv4 and ipv6 2021-02-02 19:33:22 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:25:16 UTC

Description Anping Li 2020-01-15 15:03:55 UTC
Description of problem:

Connection refused when access metrics in IPv6 Cluster


Version-Release number of selected component (if applicable):
Cluster Version:  4.3.0-0.nightly-2020-01-09-234847-ipv6.

image: quay.io/openshift/origin-logging-elasticsearch5:latest
imageID: quay.io/openshift/origin-logging-elasticsearch5@sha256:13cec4582e1b359b52980a76e682418aa91c8379e376b3e4b94653accf3429ee
image: quay.io/openshift/origin-oauth-proxy:latest
imageID: quay.io/openshift/origin-oauth-proxy@sha256:9bc48eb62fe6cc492ffdd28d874dbe7d0ebe9d24a53e230864644393fdb759b9



How reproducible:
Always

Steps to Reproduce:
1. Deploy clusterlogging
2. Access the fluentd metrics
   curl -k -H "Authorization: Bearer `oc sa get-token prometheus-k8s -n openshift-monitoring`" -H "Content-type: application/json" https://$fluentd-pod_IP:24231/metrics


Actual results:

oc get pod -o wide
NAME                                           READY   STATUS      RESTARTS   AGE     IP                          NODE                                         NOMINATED NODE   READINESS GATES
fluentd-pkfvs                                  1/1     Running     0          6h15m   fd01::1:98ee:51ff:fe00:8d   ip-10-0-147-144.us-east-2.compute.internal   <none>           <none>

$oc rsh cluster-logging-operator-545976bc54-bcssm
sh-4.2$ curl -k -g -H "Authorization: Bearer eyJhbGciOiJSUzI1NiIsImtpZCI6ImdGNmhWM21jSU42M1g5N0oyTFhEcVdGM2hTUk5rU3dGa2tKckZldlFzYUEifQ.eyJpc3MiOiJrdWJlcm5ldGVzL3NlcnZpY2VhY2NvdW5aWNlYWNjb3VudC9uYW1lc3BhY2UiOiJvcGVuc2hpZnQtbW9uaXRvcmluZyIsImt1YmVybmV0ZXMuaW8vc2VydmljZWFjY291bnQvc2VjcmV0Lm5hbWUiOiJwcm9tZXRoZXVzLWs4cy10b2tlbi1qZno0dyIsImt1YmVybmV0ZXMuaW8vc2VydmljZWFjY291bnQvc2VydmljZS1hY2NvdW50Lm5hbWUiOiJwcm9tZXRoZXVzLWs4cyIsImt1YmVybmV0ZXMuaW8vc2VydmljZWFjY291bnQvc2VydmljZS1hY2NvdW50LnVpZCI6ImU5NTE4ZWNiLTg5ZDctNDVkNC1hMWY0LTVkYzQyZDk4M2FkNSIsInN1YiI6InN5c3RlbTpzZXJ2aWNlYWNjb3VudDpvcGVuc2hpZnQtbW9uaXRvcmluZzpwcm9tZXRoZXVzLWs4cyJ9.E0jsda5aFjMeCPQQJc5bqQVEBFFNIaWDPqsiLFDeRDW5qYPutH-MnBStp7PC87zJ3OlATOo-fRNxmR6fM75QeYRrVl-XHdUdbeJma3rQMw2bo8Mz7ja1Yb4BNiN1ADXRHJaQIBQY6ZYAfHWAtt6LefgnvN2fWrqizA8XMeoQiDleHVuNy-RIBIVQRaglqNZDMT9N6V6PXiJJa7pn6pbqBUoOtDiqUHtDCve3U3ZrKrjo8ANqzfa5kzP8-FeVV4UnV_XyM4oVBB1Mqkwg8fskmHJpSJIar58KuZfmUT6fFRWYHnPw8WpgAJYUQI1khqCZnC-tbqFjt0EAd5CFKbDfJA" -H "Content-type: application/json"  "https://[fd01::1:98ee:51ff:fe00:8d]:24231/metrics"
curl: (7) Failed connect to fd01::1:98ee:51ff:fe00:8d:24231; Connection refused


Expected results:
The metrics can be retrieved.

Additional info:

Comment 1 Anping Li 2020-01-15 15:53:15 UTC
The fluend metrics service is on IPv4.

ss -anp
 users:(("fluentd",pid=1,fd=8))
tcp   LISTEN     0      128                                                                         *:24231

Comment 5 Anping Li 2020-01-30 08:37:10 UTC
Verified using the latest upstream code.

Comment 7 errata-xmlrpc 2020-05-04 11:24:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.