Bug 1791378 - ipv4.dhcp-timeout infinity is ignored
Summary: ipv4.dhcp-timeout infinity is ignored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-15 16:54 UTC by Dominik Holler
Modified: 2020-04-28 16:54 UTC (History)
14 users (show)

Fixed In Version: NetworkManager-1.22.6-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:11 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
terminal log (26.18 KB, text/plain)
2020-01-15 16:54 UTC, Dominik Holler
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:38 UTC

Description Dominik Holler 2020-01-15 16:54:24 UTC
Created attachment 1652495 [details]
terminal log

Description of problem:
Even if ipv4.dhcp-timeout is set to infinity, the connection is deactivated if the DHCP server does not respond on renewal.


Version-Release number of selected component (if applicable):
NetworkManager-1.20.0-3.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Setup bridge with dhcp and ipv4.dhcp-timeout=infinity
2. Activate the bridge, bridge will get an IP address via DHCP
3. Kill the dhcp server

Actual results:
NetworkManager deactivates the connection and removes the bridge.

Expected results:
NetworkManager keeps the connection active and the bridge can still work on layer 2.

Additional info:

Comment 7 Beniamino Galvani 2020-02-04 09:49:40 UTC
Hi, it seems to work fine here:

 # nmcli connection modify veth0+ ipv4.dhcp-timeout infinity
 # nmcli connection up veth0+ &
 [1] 17007
 # journalctl -u NetworkManager -e
 ...
 Feb 04 10:46:11 fedora NetworkManager[16447]: <info>  [1580809571.7718] device (veth0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
 Feb 04 10:46:11 fedora NetworkManager[16447]: <info>  [1580809571.7721] dhcp4 (veth0): activation: beginning transaction (no timeout)

 # nmcli --version
 nmcli tool, version 1.22.6

Are you sure the connection was reactivated after you changed the timeout?

Comment 9 Ales Musil 2020-02-11 18:05:44 UTC
It is working fine when specified on connection profile. It does not work in /etc/NetworkManager/conf.d/*.conf but int32 max is doing so this is fine by me.

Comment 10 Thomas Haller 2020-02-12 12:56:24 UTC
> It is working fine when specified on connection profile. It does not work in /etc/NetworkManager/conf.d/*.conf but int32 max is doing so this is fine by me.

Please share the exact configuration file that you used. Did you reload the configuration after editing the file? Did you leave the corresponding setting in the profile at "0", so that the default can take effect?

We might need a level=TRACE log to understand this issue.

Comment 11 Vladimir Benes 2020-02-19 14:19:02 UTC
covered by bridge_down_to_l2_only

Comment 13 errata-xmlrpc 2020-04-28 16:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.