Bug 179143 - Installer will not progress past CD 5, system unbootable
Installer will not progress past CD 5, system unbootable
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
http://insecurity.org/FC5T2_Success/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 13:27 EST by Bill Jones
Modified: 2008-03-10 20:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 20:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Jones 2006-01-27 13:27:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
The FC5 Test 2 PowerPC CD installer set does not progress past CD 5 -- the installer still shows 10 minutes left and simply reboots the system without any error indications.  I have tried this procedure 5 times using:

2 times as linux [Enter]
1 times as rescue [Enter]
2 times as linux expert [Enter]

I have tested the complete CD set and all disks tests as OK To Install from...


Version-Release number of selected component (if applicable):
FC5T2 PPC CD Installer set

How reproducible:
Always

Steps to Reproduce:
1.  Try to install the CD set on a iMac PPC


Actual Results:  CD 5 reboots for no apparent reason.

Expected Results:  The system should have installed the correct yaboot stuff -- it does not.

Additional info:

Also, the installer system cannot generate a proper Apple disc label -- so the iMAc Open Firmware doesn't correctly recognize new unformatted Hard Drives.
Comment 1 Paul Nasrat 2006-01-27 14:55:38 EST
Which iMac did you use - my iMac DV SE works fine?  Is there any information on
screen when it reboots.  What package selection did you choose?

We definitely should be creating mac disc labels - what was your disk set up
before hand?  When you say OF doesn't recognise the disk what exactly do you
mean.  Bootloader setup isn't done until after package installation.

Can you boot CD 1 with the linux rescue argument and get more information off
the system.
Comment 2 Bill Jones 2006-01-31 15:07:50 EST
My iMac is a 1999 series with slot loading CD -- it is identified as Firewire
but it does not have Firewire ports.

I tried the graphical install 6 times this past weekend; in 3 cases the
installation failed to get past the 5th CD -- the 4th attempt I tried the TEXT
based installer and it failed on the 2nd CD; the 5th attempt I installed MacOS 9
first, then I installed UBUNTU (Debian PPC) and then I installed the FC5T2 CD
set using the text installer and I selected to Wipe All Partitions and use the
default layout -- Vol Groups and stuff -- that failed.  Lastly, I went into the
rescue CD (which by the way identifys itself as a PPC64) and manually deleted
all partitions except the  first 8 -- which were installed by MacOS 90 and are
required for the Hard drive to be "blessed" by the iMac OF software.  The 6th
attempt -- text based -- was successful so the iMac is operational using FC5T2
-- but it must be shoe horned in there to work...

Bottom line - The Bootloader does not create valid Apple labels.  

I have uploaded all the logs and text files you may wish to review regarding
this weekends troubleshootig session to my server at:

http://insecurity.org/FC5T2_Success/

BTW - The TGZ file is a tarball of all of /var /etc and /root only; so you may
not need that file per se...

HTH/Bill
Comment 3 Bill Jones 2006-01-31 15:23:55 EST
BTW - I uploaded 264 files in total.
-Sx-
Comment 4 Matthew Miller 2007-04-06 14:16:06 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 Bill Jones 2007-04-08 10:04:28 EDT
Well, since I only test the RawHide stuff I am already at 7 and not using the
PowerPC platform at all.  So, from my stand point, I have no idea if it works or
not.  I will say that, at least in my situation, the fact that I was using an
old 1999 barely NewAge iMac that fact may have been a contributing factor.

Maybe someone else will be able to confirm that the PPC Fedora series can
correctly make blessed Apple disk labels.

Note You need to log in before you can comment on or make changes to this bug.