Bug 1791437 - Unable to specify OPENSHIFT_INSTALL_INVOKER when doing a UPI installation
Summary: Unable to specify OPENSHIFT_INSTALL_INVOKER when doing a UPI installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Alex Crawford
QA Contact: yangyang
URL:
Whiteboard:
: 1794602 (view as bug list)
Depends On:
Blocks: 1791440
TreeView+ depends on / blocked
 
Reported: 2020-01-15 20:19 UTC by Alex Crawford
Modified: 2020-05-04 11:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1791440 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:24:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2929 None closed Bug 1791437: asset/manifests: add openshift-install configmap 2020-07-16 14:41:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:25:16 UTC

Description Alex Crawford 2020-01-15 20:19:00 UTC
The OPENSHIFT_INSTALL_INVOKER only takes effect when doing an IPI installation. CI (and maybe others) need to use that override, even when doing a UPI installation.

Comment 1 Scott Dodson 2020-01-24 14:25:02 UTC
*** Bug 1794602 has been marked as a duplicate of this bug. ***

Comment 3 yangyang 2020-02-04 10:42:31 UTC
Verified with 4.4.0-0.nightly-2020-02-03-163409

Steps of verification are as below:
1. Set environment variable
export OPENSHIFT_INSTALL_INVOKER=yanyang

2. Install a UPI cluster on GCP

3. Check configmap
# oc get configmap -n openshift-config openshift-install -o yaml
apiVersion: v1
data:
  invoker: yanyang
  version: v4.4.0
kind: ConfigMap
metadata:
  creationTimestamp: "2020-02-04T09:52:19Z"
  name: openshift-install
  namespace: openshift-config
  resourceVersion: "926"
  selfLink: /api/v1/namespaces/openshift-config/configmaps/openshift-install
  uid: a6254f26-9ffa-4af8-8526-7c95b7d2d9dc

The test results are as expected hence moving it to verified state.

Comment 5 errata-xmlrpc 2020-05-04 11:24:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.