Bug 1791460 - ceph-iscsi spec needs to make rtslib target dirs [NEEDINFO]
Summary: ceph-iscsi spec needs to make rtslib target dirs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Mike Christie
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
: 1790956 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-15 21:26 UTC by Mike Christie
Modified: 2020-01-31 12:49 UTC (History)
4 users (show)

Fixed In Version: ceph-iscsi-3.4-3.el7cp ceph-iscsi-3.4-3.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:44 UTC
Target Upstream Version:
tchandra: needinfo? (mchristi)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:59 UTC

Description Mike Christie 2020-01-15 21:26:03 UTC
Description of problem:

rtslib now requires /etc/target or /var/target to be setup (it depends on the version). The issue is that rtslib does not make those dirs and instead relies on targetcli to make them.

For the container case we do not install targetcli, so ceph-iscsi's daemons will crash or fail to setup disks, when we make rtslib calls that try to access the etc/var target dirs.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2020-01-15 21:26:10 UTC
Please specify the severity of this bug. Severity is defined here:
https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity.

Comment 7 Ernesto Puerta 2020-01-17 10:02:34 UTC
*** Bug 1790956 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2020-01-31 12:48:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.