Bug 1791657 - [UI][Operator] Position of "Update Channel" should be prior to "Installation Mode" when Create Operator Subscription from UI.
Summary: [UI][Operator] Position of "Update Channel" should be prior to "Installation ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1813902
TreeView+ depends on / blocked
 
Reported: 2020-01-16 10:33 UTC by Wei Duan
Modified: 2020-07-13 17:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1813902 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
Create_Operator_Subscription_from_UI (130.93 KB, image/png)
2020-01-16 10:33 UTC, Wei Duan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:43 UTC

Description Wei Duan 2020-01-16 10:33:03 UTC
Created attachment 1652712 [details]
Create_Operator_Subscription_from_UI

Description of problem:
OperatorHub > Operator Subscription > Create Operator Subscription on the web, is prior to "Update Channel" now, take local storage operator for example. it can only be installed in specific namespace, after choosing the expected namespace, then if "update channel" need to be modified, the "Installation Mode" will be back to the default option(all namespace). 
Also from the configuration side, "Update Channel" has a higher level than "Installation Mode"

Version-Release number of selected component (if applicable):
OCP4.3

How reproducible:
Always

Steps to Reproduce:
See Description.

Actual results:
"Installation Mode" is prior to "Update Channel"

Expected results:
"Update Channel" is prior to "Installation Mode"

Additional info:
Comments from jiazha: the "Installation Mode" definiation located in the CSV file, and the "Update Channel"s in the package file which located in the parent folder. So, for me, I think the first step should be choosing the Channel.

Comment 3 Yanping Zhang 2020-03-17 04:05:30 UTC
Checked on OCP 4.5 cluster with payload 4.5.0-0.nightly-2020-03-16-182052. Go to operator hub, choose to install local storage operator, now the "Update Channel" is ahead of "Install Mode", install mode will change according to channel.
The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-07-13 17:13:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.