Bug 1791745 - zbar fails to build with Python 3.9: PyTypeObject has no member named 'tp_print' [NEEDINFO]
Summary: zbar fails to build with Python 3.9: PyTypeObject has no member named 'tp_print'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: zbar
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1842164 (view as bug list)
Depends On:
Blocks: PYTHON39 F33FTBFS F33FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-01-16 12:25 UTC by Miro Hrončok
Modified: 2020-07-20 18:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-20 18:21:22 UTC
Type: Bug
igor.raits: needinfo? (mchehab)


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-16 12:25:08 UTC
zbar fails to build with Python 3.9.0a2.

python/enum.c: In function 'enumitem_print':
python/enum.c:84:31: error: 'struct _typeobject' has no member named 'tp_print'
   84 |     return(self->name->ob_type->tp_print(self->name, fp, flags));
      |                               ^~
python/enum.c: At top level:
python/enum.c:118:6: error: 'PyTypeObject' {aka 'struct _typeobject'} has no member named 'tp_print'
  118 |     .tp_print       = (printfunc)enumitem_print,
      |      ^~~~~~~~
python/enum.c:118:23: warning: initialization of 'PyObject * (*)(PyObject *, PyObject *)' {aka 'struct _object * (*)(struct _object *, struct _object *)'} from 'long int' makes pointer from integer without a cast [-Wint-conversion]
  118 |     .tp_print       = (printfunc)enumitem_print,
      |                       ^
python/enum.c:118:23: note: (near initialization for 'zbarEnumItem_Type.tp_getattro')


This is confusing to me, because I thought this was already changed in Python 3.9. Anyway see https://docs.python.org/3.9/c-api/typeobj.html#c.PyTypeObject.tp_vectorcall_offset

tp_print is indeed no more.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01147646-zbar/

For all our attempts to build zbar with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/zbar/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-01-16 12:36:10 UTC
> because I thought this was already changed in Python 3.9

I meant 3.8.

Comment 2 Victor Stinner 2020-01-16 13:51:56 UTC
tp_print has been removed from Python 3.9. I opened https://bugs.python.org/issue39361 to document the removal.

This code should be made Python 2 only using #ifdef, tp_print is unused since Python 3.0.

static int
enumitem_print (zbarEnumItem *self,
                FILE *fp,
                int flags)
{
    return(self->name->ob_type->tp_print(self->name, fp, flags));
}

But also:

    .tp_print       = (printfunc)enumitem_print,

https://sourceforge.net/p/zbar/code/ci/default/tree/python/enum.c

Comment 3 Ben Cotton 2020-02-11 17:34:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 4 Miro Hrončok 2020-03-16 12:43:54 UTC
Mauro, could you please have look and report this upstream if needed? Thanks.

Comment 5 Miro Hrončok 2020-05-25 13:01:43 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 6 Miro Hrončok 2020-05-29 07:11:39 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 7 Miro Hrončok 2020-06-11 15:11:19 UTC
*** Bug 1842164 has been marked as a duplicate of this bug. ***

Comment 8 Igor Raits 2020-06-19 17:51:49 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 9 Fedora Admin user for bugzilla script actions 2020-07-18 14:53:25 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 10 Igor Raits 2020-07-20 06:19:05 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/zbar by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 11 Fedora Admin user for bugzilla script actions 2020-07-20 14:55:01 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 12 Gwyn Ciesla 2020-07-20 18:21:22 UTC
Patched, sent upstream.


Note You need to log in before you can comment on or make changes to this bug.