Bug 179178 - Pirut Exception Traceback when going into List mode for 2nd time
Pirut Exception Traceback when going into List mode for 2nd time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 16:15 EST by Jason Knight
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 16:36:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Knight 2006-01-27 16:15:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I was playing around with Pirut and went into list, clicked to available packages Then I went back to browse, then back to List mode, and at this point an exception popped up and told me to report it:



Version-Release number of selected component (if applicable):
pirut-0.9.2-1

How reproducible:
Always

Steps to Reproduce:
1. go to list
2. go to available packages
3. go back to browse, then back to browse
  

Actual Results:  I reproduced this twice, so if you need anymore help, just ask.

Additional info:

Component: Software Manager
Summary: TB085d19a0 pirut:228:__filter_package_list:AttributeError: 'NoneType' object has no attribute 'repoid'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 228, in __filter_package_list
    elif self._showPackageType == SHOW_AVAIL and po.repoid == "installed":
AttributeError: 'NoneType' object has no attribute 'repoid'

Local variables in innermost frame:
i: <GtkTreeIter at 0xbea2c10>
model: <gtk.ListStore object (GtkListStore) at 0xb4a345a4>
po: None
self: <__main__.PackageManager object at 0xb79b56cc>
Comment 1 Jeremy Katz 2006-01-28 00:57:35 EST
I can't reproduce this with the current version of pirut -- does it still occur
with pirut-0.9.7?
Comment 2 Jason Knight 2006-01-28 10:31:43 EST
Okay, yes this issue is fixed with pirut-0.9.7-1, although i am having other
issues like: Cannot select any packages in "Available Packages" and no packages
are listed in the Installed Packages.
Comment 3 Jeremy Katz 2006-02-03 16:36:16 EST
Should all be fixed for 0.9.9

Note You need to log in before you can comment on or make changes to this bug.