Bug 1791988 - After upgrade from 4.3 to 4.4, NTO cannot get resource "nodes" in API group
Summary: After upgrade from 4.3 to 4.4, NTO cannot get resource "nodes" in API group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jiří Mencák
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-16 19:59 UTC by Simon
Modified: 2020-05-04 11:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:24:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:25:19 UTC

Description Simon 2020-01-16 19:59:50 UTC
Description of problem:
After upgrade from 4.3 to 4.4 node tuning operator cannot get resources "node" in API group.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
1. Create OCP 4.3 cluster.
2. Update to version 4.4
oc patch clusterversion/version --patch '{"spec":{"upstream":"https://openshift-release.svc.ci.openshift.org/graph"}}' --type=merge

oc adm upgrade --to-image=registry.svc.ci.openshift.org/ocp/release:4.4.0-0.nightly-2020-01-16-103546 --allow-explicit-upgrade --force

3. Check logs in tuned pods.

Actual results:
On each node the same:

I0116 18:16:04.422258    7008 openshift-tuned.go:550] Pod (openshift-kube-storage-version-migrator/migrator-76ff7f7965-6nz6g) labels changed node wide: true
I0116 18:16:05.357354    7008 openshift-tuned.go:408] Dumping labels to /var/lib/tuned/ocp-pod-labels.cfg
I0116 18:16:05.358560    7008 openshift-tuned.go:441] Getting recommended profile...
I0116 18:16:05.451877    7008 openshift-tuned.go:638] Active and recommended profile (openshift-node) match.  Label changes will not trigger profile reload.
E0116 18:16:29.348558    7008 openshift-tuned.go:881] Error getting node ip-10-0-48-132.us-east-2.compute.internal: nodes "ip-10-0-48-132.us-east-2.compute.internal" is forbidden: User "system:serviceaccount:openshift-cluster-node-tuning-operator:tuned" cannot get resource "nodes" in API group "" at the cluster scope
I0116 18:16:29.348576    7008 openshift-tuned.go:883] Increasing resyncPeriod to 102
I0116 18:18:11.348742    7008 openshift-tuned.go:209] Extracting tuned profiles
I0116 18:18:11.350230    7008 openshift-tuned.go:739] Resync period to pull node/pod labels: 102 [s]
E0116 18:18:11.355820    7008 openshift-tuned.go:881] Error getting node ip-10-0-48-132.us-east-2.compute.internal: nodes "ip-10-0-48-132.us-east-2.compute.internal" is forbidden: User "system:serviceaccount:openshift-cluster-node-tuning-operator:tuned" cannot get resource "nodes" in API group "" at the cluster scope
I0116 18:18:11.355836    7008 openshift-tuned.go:883] Increasing resyncPeriod to 204
I0116 18:21:35.356153    7008 openshift-tuned.go:209] Extracting tuned profiles

Comment 1 Jiří Mencák 2020-01-17 14:56:27 UTC
Proposed upstream fix:
https://github.com/openshift/cluster-node-tuning-operator/pull/103

Comment 3 Simon 2020-01-28 19:40:24 UTC
Verification positive!

After upgrade from 4.3.0-0.nightly-2020-01-26-134543 -> 4.4.0-0.nightly-2020-01-24-141203

there is no more problems with getting 'node' resources.

Comment 5 errata-xmlrpc 2020-05-04 11:24:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.