Bug 179211 - firstboot_module_window missing module
firstboot_module_window missing module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 02:13 EST by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 12:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2006-01-28 02:13:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
ssh'd to a machine here and running Kadischi with the --graphical switch, brings up the Anaconda window and I choose my language, English. Click forward and it says: "An error occurred when attempting to load an installer interface component.
className = KeyboardWindow"

So I click exit, and in the shell I'm in I also see this:
***  running anaconda  ***

Probing for video card:   S3 Inc. 86c325 [ViRGE]
Probing for monitor type:   Unknown monitor
Starting graphical installation...
No module named firstboot_module_window

  ***  anaconda has finished the job ***

The Anaconda parts are "No module named firstboot_module_window".
The rest of that output is what Kadischi would say.
So I'm imagining this wasn't supposed to happen, though Anaconda runs under text mode just fine.


Version-Release number of selected component (if applicable):
anaconda-10.91.7-1

How reproducible:
Always

Steps to Reproduce:
1. kadischi --graphical /pub/development /tmp/rawhide00.iso
2. Anaconda graphical windows appear.
3. Choose Language, click Next.
  

Actual Results:  The module firstboot_module_window caused Anaconda to produce an error.

Expected Results:  Graphical install of LiveCD should have continued, and finish correctly.
This however isn't special to this setup, I do not believe.

Additional info:

No additional information at this time.
Comment 1 Chris Lumens 2006-01-30 10:21:30 EST
Does your stage2 tree have /usr/share/firstboot/firstboot_module_window.py in it?
Comment 2 Jasper O. Hartline 2006-01-30 17:25:54 EST
Yes, stage2.img has this module, I looked into this further and upon discovering
firstboot_module_window.py belongs to firstboot package and
firstboot_gui_window.py is deprecated I suppose this isn't an Anaconda issue
anymore.

I did however discover /usr/lib/anaconda/iw/package_gui.py was in stage2.img but
not on disk though I do have anaconda-10.91.8-1 package installed, which is in
fact an update from 10.91.7-1. Maybe this bug report is relevant after all?
:-D
Comment 3 Jasper O. Hartline 2006-02-01 11:55:06 EST
I just updated Anaconda to 10.91.11-1 and package_gui.py is now present.
I know this is a mundane sort of "bug", but surely this file was supposed to be
included! 

Looks like it is fixed.
I'll be sure to report any other anomalies I find!
Thanks for your time.


Note You need to log in before you can comment on or make changes to this bug.