Bug 179224 - RFE: please upgrade to current version, also please package sample configs
RFE: please upgrade to current version, also please package sample configs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shorewall (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Marcano
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 10:47 EST by Jonathan Underwood
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 13:39:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2006-01-28 10:47:26 EST
Description of problem:
currently available version is very out of date.
Also, current RPM does not package the sample configurations, which should be
packaged as part of the documentation (they are in the tarball)

Version-Release number of selected component (if applicable):
shorewall-2.4.6-1.fc4

How reproducible:
every time

Steps to Reproduce:
1. yum install shorewall
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Marcano 2006-01-28 16:36:13 EST
Correct, I will be adding the sample configurations on the next update.

The FC5 extras reporsitory has the latest 3.0.4 release, I have not upgraded the
FC4 version because 3.0.x version is not a direct replacement for 2.4.x,
configuration files format has been changed and others have been removed. The
shorewall relase notes says that the old configuration is being supported only
if the shorewall.conf is not udpated to the new format. This can be a problem if
someone installed the 2.4.x RPM and never modified the shorewall.conf file, It
will simply will be replaced with the 3.0.x version.

What are you experiences upgrading to 3.0 without modifing 2.4.x files?
Comment 2 Jonathan Underwood 2006-01-28 23:04:34 EST
OK, understood. I have seen packages that move old config files out of the way
when this happens, alerting the user to the fact (i.e. foo.cong ->
foo.conf.rpmsave by postun), but that could be tricky here - people's firewall
could break and they wouldn't notice. Not sure what the best plan of attack
would be. Perhaps making a shorewall3 package available for FC4?

I haven't tried upgrading to 3 keeping the 2.4 files. Rather I installed 2.4,
and then began editing the files according to the 3.0 documentation, which
obviously didn't work, and then I noticed the package was the older version.
When I find some time I may try installing the FC5 package over the 2.4 package
and see what breaks. Stands to reason it won't work tho.
Comment 3 Robert Marcano 2006-02-08 13:39:33 EST
After testing the upgrade from 2.4.x to 3.0.x on two diferent servers with
diferent shorewall configurations, everything worked as spected using the
backwards compatibility of shorewall, to use the new features, the configuration
files will need to be updated

Note You need to log in before you can comment on or make changes to this bug.