Bug 1792293 - Review Request: php-laminas-escaper - Laminas Framework Escaper component
Summary: Review Request: php-laminas-escaper - Laminas Framework Escaper component
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robert-André Mauchin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1792281 1792291
Blocks: 1792297
TreeView+ depends on / blocked
 
Reported: 2020-01-17 13:42 UTC by Remi Collet
Modified: 2020-01-23 14:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 14:47:48 UTC
zebob.m: fedora-review+


Attachments (Terms of Use)

Description Remi Collet 2020-01-17 13:42:12 UTC
Spec URL: https://git.remirepo.net/cgit/rpms/php/laminas/php-laminas-escaper.git/plain/php-laminas-escaper.spec?id=e427f9bd9a6631087b4fdad41d81ff4fb4bb8e43
SRPM URL: http://rpms.remirepo.net/SRPMS/php-laminas-escaper-2.6.1-2.remi.src.rpm
Description: 
The OWASP Top 10 web security risks study lists Cross-Site Scripting (XSS)
in second place. PHP’s sole functionality against XSS is limited to two
functions of which one is commonly misapplied. Thus, the laminas-escaper
component was written. It offers developers a way to escape output and defend
from XSS and related vulnerabilities by introducing contextual escaping based
on peer-reviewed rules.

Documentation: https://docs.laminas.dev/laminas-escaper/


Fedora Account System Username: remi

Comment 1 Robert-André Mauchin 2020-01-22 17:50:27 UTC
 - License ok
 - Latest version packaged
 - Builds in mock
 - No rpmlint errors
 - Tests are ok
 - Conforms to Packaging Guidelines

Package approved.

Comment 2 Gwyn Ciesla 2020-01-23 14:09:57 UTC
(fedscm-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/php-laminas-escaper

Comment 3 Remi Collet 2020-01-23 14:47:48 UTC
Thanks!

Built in rawhide


Note You need to log in before you can comment on or make changes to this bug.