Bug 1792386 - openshift-apiserver operand version is not being reported
Summary: openshift-apiserver operand version is not being reported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: David Eads
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-17 15:27 UTC by Ben Parees
Modified: 2020-05-04 11:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-openshift-apiserver-operator pull 303 0 None closed bug 1792386: set the operand version and make the CVO wait 2020-05-21 15:44:00 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:25:35 UTC

Description Ben Parees 2020-01-17 15:27:18 UTC
Description of problem:

the openshift-apiserver clusteroperator object has a version field for "openshift-apiserver" but the value is blank:

   versions:
    - name: operator
      version: 4.3.0-0.ci-2020-01-16-130733
    - name: openshift-apiserver
      version: ""




How reproducible:
always?  (I saw this on a clean 4.3 install, but we also saw it in an 4.2->4.3 upgrade test where the upgrade went badly).

Comment 3 Xingxing Xia 2020-01-22 08:22:01 UTC
Verified in 4.4.0-0.nightly-2020-01-22-025803 env, version for operand is not blank now:
oc get co openshift-apiserver -o yaml
...
  versions:
  - name: operator
    version: 4.4.0-0.nightly-2020-01-22-025803
  - name: openshift-apiserver
    version: 4.4.0-0.nightly-2020-01-22-025803

Comment 5 errata-xmlrpc 2020-05-04 11:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.