Bug 1792498 - No delete node action in console [openshift-4.4]
Summary: No delete node action in console [openshift-4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Jiri Tomasek
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-17 18:16 UTC by Clayton Coleman
Modified: 2020-05-04 11:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:25:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Warning info when deleting node (102.32 KB, image/png)
2020-02-07 10:08 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4154 None open Bug 1792498: Add delete action to Node 2020-02-03 14:17:30 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:25:55 UTC

Description Clayton Coleman 2020-01-17 18:16:06 UTC
From node details page you cannot delete a node.

Deleting a node comes with some consequences that we need to communicate to users, so deleting nodes should have a form like deleting projects where you are warned about the implications, then required to do something abnormal.

The text should read:

This action cannot be undone. Deleting a node will instruct Kubernetes that the node is down or unrecoverable and delete all pods scheduled to that node. If the node is still running but unresponsive and the node is deleted, stateful workloads and persistent volumes may suffer corruption or data loss. Only delete a node that you have confirmed is completely stopped and cannot be restored.

Comment 2 XiaochuanWang 2020-02-07 10:08:47 UTC
Created attachment 1661646 [details]
Warning info when deleting node

Comment 3 XiaochuanWang 2020-02-07 10:10:30 UTC
Warning message shows up when user trying to delete node on nodes list page or node detail kebab.
Attached the message screenshot.
Verified on 4.4.0-0.nightly-2020-02-05-220946

Comment 5 errata-xmlrpc 2020-05-04 11:25:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.