Bug 179254 - choose a packages within a group without checking all the group
choose a packages within a group without checking all the group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 02:38 EST by Vitaly A. Sorokin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 12:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitaly A. Sorokin 2006-01-29 02:38:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.1

Description of problem:
Hi guys,

The button 'optional components' should be enabled always - it should just 'show 0 of N components selected' to let user select one package from a group instead of switching many other packages off to get one checked option left.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
just run the installer

Additional info:
Comment 1 David Timms 2006-01-30 07:10:57 EST
Vitaly: I made a fedora-test-list query a few weeks back, with a potential
solution to solve the situation you describe:
http://marc.theaimsgroup.com/?l=fedora-test-list&m=113804310319006&w=2

This would mean you right click in the right hand side, and get a context menu:
select none,
select defaults,
select all

So to achieve selecting just one optional package from the group, you would:
right click, select none
click the checkbox of the item you do want.

I'd like to add:
[select only this package] also as a right click selection.

Comment 2 David Timms 2006-01-30 07:15:18 EST
This is the proposed UI solution:
> OK, I was going to file an enh request regarding this, but since there is lots
of opines here, what do people think of the following as a solution to the
various views expressed:
> 1. Everything option (stays) removed.
>
> 2. For the list at left (the general groups), a right click popup is provided,
with two options.
>  a. unselect all [?ctrl-shift-a (gimp) not sure what other appz standardize on]
> All groups would be deselected, leave only the "base operating system" (for
firewall / special builders)
>  b. select all - [ctrl-a]
>  c. select all - default optional components
> All default parts of each of the 6? groups would be selected.
>
> 3. For each package sub group (RHS) with options: again a right click popup is
provided with the same three options:
>  a. as above
>  b. as above
>  c. default selections (so if you make a mistake you can easily go back,
without restarting the installer - Probably also good for the left list as well.
>
> Coding could be pretty simple (for items in chosen list, check= on/off, not
sure about the default selects - ignore for v1?)...(same in text mode installer!)
>
> Anyway, good potential solution ???  DaveT.

Umm, reply to self since got no starters ; ) given the long winded and poorly
named discussion in "FC5T2 ready for even a test release?", I though it better
to start a thread with an actual subject indicating the matter at hand.

Rahul: would a method to achieve lots of peoples goals like the one above not
kill multiple birds with the one stone: ?
1. The UI stays neet, no special checkboxes.
2. Normal users probably wont find the option (hidden in a right click),
reducing it's actual use to special case where people need it, and who'll learn
how to do it.
3. Makes it much quicker for the user to install none of the options within a
category.
4. Makes it much quicker for the user to install all options within a category.
(even if only to have a minimum no of packages to unselect to get ehat you
really wanted).
5. Make it easy to select the installers defaults again.
What say you all ?

My point of view was getting a minimumish install on a low space/spec machine. I
spent probably close to ten minutes going to each category, and then unselecting
each optional item that I didn't want to get installed.  The programming to
achieve the same would probably have taken the same amount of time, and it would
be sown once and reaped forever, for minimal/maximal users alike.
===
Note that in regards to the discussed (see list) "everything installation": that
is different because people mean it to include packages that are not listed in
the packages listed in each group.
Comment 3 Jeremy Katz 2006-02-06 12:04:09 EST
If you right click on a group now, you get a choice of selecting all the
optional packages.

Note You need to log in before you can comment on or make changes to this bug.