Bug 179256 - Error about Java runtime and /usr/lib/libgcj.so.6
Error about Java runtime and /usr/lib/libgcj.so.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 04:16 EST by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1.1-9.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 04:52:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 52792 None None None Never

  None (edit)
Description Russell Coker 2006-01-29 04:16:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
When I run ooimpress and press F5 for a full-screen display I get a dialog box 
saying that the JRE is defective and the message "[Java 
framework]sunjavaplugin.so could not load Java runtime library: 
file:///usr/lib/libgcj.so.6." is displayed on standard output. 
 
The presentations in question are on 
http://www.coker.com.au/selinux/talks/rh-2006/ 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Load up tut-1-core.odp or tut-2-mcs-mls.odp from the above URL.g  

Additional info:
Comment 1 Caolan McNamara 2006-01-30 04:15:00 EST
Do what the message tells you to do. It's telling you that since it
auto-detected java originally on your machine (from gcc 4.0.0 libgcj.so.6) that
the jvm providing library has disappeared (which is true as gcc 4.0.1 moved to
libgcj.so.7). i.e. tools->options->openoffice.org->java
Comment 2 Caolan McNamara 2006-01-30 04:42:46 EST
let's see if we can silently catch this a re-detect java to pick up libgcj.so.7
in this case.
Comment 3 Caolan McNamara 2006-01-30 09:56:53 EST
patch appears to work, will be in next respin

Note You need to log in before you can comment on or make changes to this bug.