Bug 179257 - ooimpress crashes
ooimpress crashes
Status: CLOSED DUPLICATE of bug 179519
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
http://www.coker.com.au/selinux/talks...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 04:18 EST by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 04:22:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2006-01-29 04:18:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
The ODP file at the above URL crashes ooimpress version 2.0.1.1-8.2. 
  
Video Driver is probably ati   
DESKTOP_SESSION is set to kde   
libgcj version is libgcj-4.1.0-0.14   
OpenOffice.org core rpm version is openoffice.org-core-2.0.1.1-8.2   
0x4563694: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e694   
0x4563ee2: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eee2   
0x984420:  + 0x420 (__kernel_sigreturn + 0x0)   
0x90dd4c: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x45d4c   
(ucbhelper::cancelCommandExecution(com::sun::star::ucb::IOErrorCode,   
com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&,   
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment>   
const&, rtl::OUString const&,   
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandProcessor> const&)   
+ 0x170)   
0x1bc4556: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x2d556   
0x1bb6174: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x1f174   
0x1ba2dd7: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xbdd7   
0x1ba666b: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xf66b   
0x8e36a5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1b6a5   
0x8e3873: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1b873   
(ucb::Content::executeCommand(rtl::OUString const&, com::sun::star::uno::Any   
const&) + 0x4b)   
0x895e53: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x3be53   
0x897b04: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x3db04   
(utl::UcbLockBytes::CreateLockBytes(com::sun::star::uno::Reference<com::sun::star::ucb::XContent>   
const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>   
const&, unsigned short,   
com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler>   
const&, utl::UcbLockBytesHandler*) + 0x2f6)   
0x8a12d6: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x472d6   
0x8a14f5: /usr/lib/openoffice.org2.0/program/libutl680li.so + 0x474f5   
(utl::UcbStreamHelper::CreateStream(String const&, unsigned short,   
utl::UcbLockBytesHandler*, unsigned char) + 0x33)   
0x16a6964: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa2964   
0x179ea8a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19aa8a   
0x179ebfb: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19abfb   
(SfxDispatcher::SfxDispatcher(SfxDispatcher*) + 0x27)   
0x16a3ced: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9fced   
0x16b1b79: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xadb79   
(SfxApplication::SetApp(SfxApplication*) + 0xa7)   
0x16b1f1c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xadf1c   
(SfxApplication::GetOrCreate() + 0x50)   
0x168d8b4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x898b4   
0x17b62d7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b22d7   
0x17b644d: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b244d   
0x3c8a1c1: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +   
0x251c1   
0x3c89eb7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +   
0x24eb7   
0x3c89f1e: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +   
0x24f1e   
0x3c8b946: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +   
0x26946   
0x3c89eb7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +   
0x24eb7   
0x3c89f6f: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +   
0x24f6f   
0x424c1f2: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x81f2   
0x424a23b: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x623b   
0x7092b7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x262b7   
(desktop::Desktop::Main() + 0x913)   
0x57ca16a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8616a   
0x57ca21d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8621d   
(SVMain() + 0x2b)   
0x702a8b: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1fa8b (sal_main   
+ 0x57)   
0x702ad7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1fad7 (main +   
0x27)   
0x7486b4: /lib/libc.so.6 + 0x156b4 (__libc_start_main + 0xdc)   
0x80484c5: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4c5   
   

Version-Release number of selected component (if applicable):
2.0.1.1-8.2

How reproducible:
Always

Steps to Reproduce:
Load the ODP file in question. 

Additional info:
Comment 1 Caolan McNamara 2006-01-30 04:57:17 EST
That trace is one I've seen before, and for the life of me I cannot ever
reproduce it, now that a redhaty has got it, can I get absolutely *everything*
that might be relevent to reproducing this.

a) does it happen under gnome as well as kde ?
b) what selinux settings do you have if any ?
c) can I get strace -f /usr/lib/openoffice.org2.0/program/soffice.bin -writer >
/tmp/run.log 2>&1 log
d) if at all possible with debuginfo installed can I get

> gdb /usr/lib/openoffice.org2.0/program/soffice.bin
(gdb) handle SIG33 nostop noprint
(gdb) handle SIGXCPU nostop noprint
(gdb) handle SIGPWR nostop noprint
(gdb) run -writer
(gdb) bt

e) anything suspicious in /var/log/messages ?
Comment 2 Caolan McNamara 2006-02-01 04:22:25 EST
what's your kernel version ?

*** This bug has been marked as a duplicate of 179519 ***

Note You need to log in before you can comment on or make changes to this bug.