Bug 1792570 - Unable to add ansible tower to cloud forms automation.
Summary: Unable to add ansible tower to cloud forms automation.
Keywords:
Status: CLOSED DUPLICATE of bug 1740860
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.10.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Adam Grare
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-18 03:00 UTC by Saif Ali
Modified: 2020-07-15 14:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-20 18:48:14 UTC
Category: ---
Cloudforms Team: Ansible
Target Upstream Version:


Attachments (Terms of Use)

Description Saif Ali 2020-01-18 03:00:58 UTC
Description of problem:
CloudForm complaining about "vault_password" during the provider refresh when we add Tower 3.6.2 provider if we create vault_password in tower side the provider refresh success without any issue.

[----] I, [2020-01-10T07:13:44.179012 #31092:2b25946805bc]  INFO -- : Exception in realtime_block :ems_refresh - Timings: {:coll
ect_inventory_for_targets=>1.2606401443481445, :parse_targeted_inventory=>6.30631947517395, :ems_refresh=>7.567134141921997}
[----] E, [2020-01-10T07:13:44.179217 #31092:2b25946805bc] ERROR -- : MIQ(ManageIQ::Providers::AnsibleTower::AutomationManager::
Refresher#refresh) EMS: [MGMT-RHEL-Ansible01 Automation Manager], id: [1000000000009] Refresh failed
[----] E, [2020-01-10T07:13:44.181216 #31092:2b25946805bc] ERROR -- : [NoMethodError]: undefined method `vault_password' for <AnsibleTowerClient::Credential::Inputs username="admin">:AnsibleTowerClient::Credential::Inputs  Method:[block (2 levels) in <class:LogProxy>]
[----] E, [2020-01-10T07:13:44.181304 #31092:2b25946805bc] ERROR -- : /opt/rh/cfme-gemset/gems/ansible_tower_client-0.20.1/lib/ansible_tower_client/base_models/credential.rb:42:in `vault_password'
/opt/rh/cfme-gemset/bundler/gems/cfme-providers-ansible_tower-cdc04865ff9a/app/models/manageiq/providers/ansible_tower/shared/inventory/parser/automation_manager.rb:134:in `block in credentials'
/opt/rh/cfme-gemset/gems/ansible_tower_client-0.20.1/lib/ansible_tower_client/collection.rb:25:in `yield'
/opt/rh/cfme-gemset/gems/ansible_tower_client-0.20.1/lib/ansible_tower_client/collection.rb:25:in `block (2 levels) in find_all_by_url'
/opt/rh/cfme-gemset/gems/ansible_tower_client-0.20.1/lib/ansible_tower_client/collection.rb:21:in `loop'
/opt/rh/cfme-gemset/gems/ansible_tower_client-0.20.1/lib/ansible_tower_client/collection.rb:21:in `block in find_all_by_url'
/opt/rh/cfme-gemset/bundler/gems/cfme-providers-ansible_tower-cdc04865ff9a/app/models/manageiq/providers/ansible_tower/shared/inventory/parser/automation_manager.rb:129:in `each'
/opt/rh/cfme-gemset/bundler/gems/cfme-providers-ansible_tower-cdc04865ff9a/app/models/manageiq/providers/ansible_tower/shared/inventory/parser/automation_manager.rb:129:in `each'
/opt/rh/cfme-gemset/bundler/gems/cfme-providers-ansible_tower-cdc04865ff9a/app/models/manageiq/providers/ansible_tower/shared/inventory/parser/automation_manager.rb:129:in `credentials'
/opt/rh/cfme-gemset/bundler/gems/cfme-providers-ansible_tower-cdc04865ff9a/app/models/manageiq/providers/ansible_tower/shared/inventory/parser/automation_manager.rb:9:in `parse'
/var/www/miq/vmdb/app/models/manageiq/providers/inventory.rb:42:in `block in parse'
/var/www/miq/vmdb/app/models/manageiq/providers/inventory.rb:39:in `each'
/var/www/miq/vmdb/app/models/manageiq/providers/inventory.rb:39:in `parse'
/var/www/miq/vmdb/app/models/manageiq/providers/base_manager/refresher.rb:141:in `parse_targeted_inventory'
/var/www/miq/vmdb/app/models/manageiq/providers/base_manager/refresher.rb:92:in `block in refresh_targets_for_ems'
/opt/rh/cfme-gemset/bundler/gems/cfme-gems-pending-b7122ae0baec/lib/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/opt/rh/cfme-gemset/bundler/gems/cfme-gems-pending-b7122ae0baec/lib/gems/pending/util/extensions/miq-benchmark.rb:28:in `realtime_block'
/var/www/miq/vmdb/app/models/manageiq/providers/base_manager/refresher.rb:91:in `refresh_targets_for_ems'

Version-Release number of selected component (if applicable):
CF 5.11.1.2
Tower 3.6.2
How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Adam Grare 2020-01-20 18:48:14 UTC

*** This bug has been marked as a duplicate of bug 1740860 ***


Note You need to log in before you can comment on or make changes to this bug.