Bug 179261 - Screensaver uses 100% CPU
Screensaver uses 100% CPU
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 05:47 EST by Damien
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 12:28:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damien 2006-01-29 05:47:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
When using any of the screensavers included except for the "blank screen" option, the CPU usage tends towards 100%.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.13.5-4

How reproducible:
Always

Steps to Reproduce:
1.Go to "System" -> "Preferences" -> "Screensaver"
2.Choose "fedora floating bubbles" from configuration screen.
3.Make sure system monitor applet is in panel.
4.Let screensaver activate.
5.Interupt screensaver,

  

Actual Results:  6.Note system monitor applet shows CPU usage had been at close to, or at 100%.

Expected Results:  CPU usage should have been lower, at least nowhere near 100%.

Additional info:

Whilst this may not be a problem for desktop PC's it certainly is on portable devices, especially when on battery power.
Perhaps it would be worthwhile having some sort of "screensaver profile" so that CPU intensive screensavers would only be activated when mains power is conected?
Comment 1 Rahul Sundaram 2006-02-20 06:33:21 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 jmccann 2006-04-26 12:12:13 EDT
This can probably be closed.  Ray has made a few changes to the floaters engine
to make it use less CPU and in 2.14 gnome-power-manager throttles the
screensaver when not on AC power.
Comment 3 Rahul Sundaram 2006-04-26 12:28:11 EDT

Thanks for the feedback. Closing. 

Note You need to log in before you can comment on or make changes to this bug.