Bug 1792693 - Remove Create Pipeline button when getting started guide is enabled
Summary: Remove Create Pipeline button when getting started guide is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-19 07:30 UTC by Yadan Pei
Modified: 2020-07-13 17:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The pipeline page was inconsistent with other pages. The Create Pipeline button was enabled always and did not take into consideration when no projects were available. Consequence: Inconsistent page with Create Pipeline button present. Fix: Removed the create Pipeline button when getting started guide is enabled. Result: Create Pipeline button is no longer present when getting started guide is enabled.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
Consistent Started Guideline (263.40 KB, image/png)
2020-06-01 01:58 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5610 None closed Bug 1792693: add withStartGuide to dev-console pages 2020-06-23 08:20:39 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:13:43 UTC

Description Yadan Pei 2020-01-19 07:30:24 UTC
Description of problem:
Create Pipeline button should be removed when getting started guide is enabled on Pipelines page, same issue with https://bugzilla.redhat.com/show_bug.cgi?id=1785487, but open a different bug to track https://bugzilla.redhat.com/show_bug.cgi?id=1785487#c9

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-01-18-223038

How reproducible:
ALways

Steps to Reproduce:
1. admin user install OpenShift Pipelines Operator 
2. normal user without any project visit Pipelines -> Pipelines page


Actual results:
2. it will show 'No Pipelines Found' but there's a disabled Create Pipeline button

Expected results:
2. Create Pipeline button should be removed when getting started guide is enabled, such as what we show on other resources page

Additional info:

Comment 1 Andrew Ballantyne 2020-01-20 19:26:02 UTC
Jira backlog ticket: https://issues.redhat.com/browse/ODC-2773

Comment 2 spathak@redhat.com 2020-03-20 11:07:25 UTC
What role does the user have?

Comment 5 Yadan Pei 2020-06-01 01:58:32 UTC
Created attachment 1693975 [details]
Consistent Started Guideline

When starting guideline message is shown, Pipelines -> Pipelines page doesn't show `Create Pipelines` button, this is consistent with other resource pages

Verified on 4.5.0-0.nightly-2020-05-30-025738

Comment 7 errata-xmlrpc 2020-07-13 17:13:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.