Bug 179276 - Request for kernel-module-ntfs inclusion in fedora extras
Request for kernel-module-ntfs inclusion in fedora extras
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Greg DeKoenigsberg
David Lawrence
http://linux-ntfs.org
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 14:41 EST by Christopher Brown
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 07:16:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Brown 2006-01-29 14:41:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Hello,

This request is made on behalf of the linux-ntfs project listed at the above URL. Yes, I am fully aware of http://fedoraproject.org/wiki/ForbiddenItems and the statement regarding inclusion of the ntfs driver in Core. Before this request is turned down outright could everyone please consider the following:

1. RHEL and Fedora are the last remaining distribution/s not to include the NTFS driver. Does the lack of legal action against other distributions not set a legal precedent?
2. Inclusion of the NTFS kernel module in Extras would surely shift some burden of responsibility from RH and leave the decision of NTFS support in the users hands, whilst providing an easier route through default YUM repos to getting that support should it be required. ie. RH/Fedora are not shipping support in Core and therefore distancing themselves a little from any concerns they may have. Fundamentally, can this be considered an acceptable compromise?
3. An awful lot of time (developer time) is spent packaging RPMS - if buildsys can handle this then they can get on with more important stuff. Hint, hint, write support, hint, hint.

I realise this is not the reason the RFC was published however I recognised the opportunity when it arose and as a boundary to cross-platform compatibility for users migrating I feel this alterative to straight kernel inclusion should be given some serious thought.

In answer to the other questions, this would be GPL and obviously the reason it is not in mainline (Fedora mainline that is) is for those mentioned numerous times previously.

Version-Release number of selected component (if applicable):
kernel-module-ntfs-$(uname -r)

How reproducible:
Always

Steps to Reproduce:
See above.

Additional info:
Comment 1 Dennis Gilmore 2006-01-30 18:46:46 EST
http://fedoraproject.org/wiki/ForbiddenItems  clearly states thats ntfs  is  
not allowed.  the same reasons for ntfs support not being in core also effect 
extras.  i would suggest you look at a third party repo  possibly livna.   
Comment 2 Alex Lancaster 2006-01-30 21:24:24 EST
Already in Livna:

http://rpm.livna.org/fedora/4/i386/RPMS.lvn/repodata/repoview/kernel-module-ntfs-2.6.14-1.1656_FC4-0-2.1.22-0.lvn.3.4.html

I guess Christopher knows about that, but was hoping that Extras might
reconsider ntfs (he did acknowledgement the existence of that page).  I guess a
better place to open that discussion would be on fedora-extras-list, but I
wouldn't hold out much hope if it's already been through once with the Red Hat
legal team.

The only difference about it being in livna is that people have to jump through
the extra hoop of downloading the livna-release rpm to set it up.  Some of the
same maintainers of Extras work on Livna.
Comment 3 Alex Lancaster 2006-01-30 21:25:55 EST
(In reply to comment #2)
> Already in Livna:
> 
>
http://rpm.livna.org/fedora/4/i386/RPMS.lvn/repodata/repoview/kernel-module-ntfs-2.6.14-1.1656_FC4-0-2.1.22-0.lvn.3.4.html
> 
> I guess Christopher knows about that, 

I meant the forbidden items page (not the Livna page)

http://fedoraproject.org/wiki/ForbiddenItems  
Comment 4 Christopher Brown 2006-02-02 07:07:58 EST
In reply to Comment #1 I was hoping that instead of an outright "no this wont
work" people would be willing to re-visit the possibility of the inclusion of
ntfs support. 

Also remember mono was also listed under forbidden items until recently so I do
not consider it a be all and end all. I am of course aware of third party repos
such as livna and the excellent job they do etc etc. however my hope is that by
NOT shipping with core and instead using a kernel module in extras we could
compromise a little.

Remember, the code is not a wrapper for some ntfs driver, it is GPL'd and
written and available due to the damn hard work of some fine developers. If we
are to reject inclusion of NTFS support in the kernel then by dint we should
also be removing FAT support (see recently upheld patents on this baby) and
SAMBA should also give us cause for concern as it was developed using similar
methods.

Regards
Chris
Comment 5 Rahul Sundaram 2006-02-02 07:16:30 EST
(In reply to comment #4)
> In reply to Comment #1 I was hoping that instead of an outright "no this wont
> work" people would be willing to re-visit the possibility of the inclusion of
> ntfs support. 
> 
> Also remember mono was also listed under forbidden items until recently so I do
> not consider it a be all and end all. I am of course aware of third party repos
> such as livna and the excellent job they do etc etc. however my hope is that by
> NOT shipping with core and instead using a kernel module in extras we could
> compromise a little.
> 
> Remember, the code is not a wrapper for some ntfs driver, it is GPL'd and
> written and available due to the damn hard work of some fine developers. If we
> are to reject inclusion of NTFS support in the kernel then by dint we should
> also be removing FAT support (see recently upheld patents on this baby) and
> SAMBA should also give us cause for concern as it was developed using similar
> methods.
> 
> Regards
> Chris

ForbiddenItems mentioned mono as a open issue which has now been resolved. NTFS
has already been excluded by the counsel. Apparently FAT, Samba etc are
different from the legal standpoint.Refer to
http://fedoraproject.org/wiki/ForbiddenItems and
http://fedoraproject.org/wiki/FedoraLegalIssues for some of the details.

If you wish to discuss this further kindly bring it to the fedora-extras list or
contact the legal gateway

http://fedora.redhat.com/About/contact.html

gdk AT fedoraproject.org
Comment 6 Alex Lancaster 2006-02-02 07:24:37 EST
(In reply to comment #4)
> In reply to Comment #1 I was hoping that instead of an outright "no this wont
> work" people would be willing to re-visit the possibility of the inclusion of
> ntfs support. 

For what it's worth, I agree, I would prefer to see ntfs in Extras, for
convenience.  However bugzilla entry is probably not the best place to have a
discussion in general (even though this is posted to the fedora-extras-list)
unless it specifically about packaging related methods.   

http://producingoss.com/html-chunk/bug-tracker.html#bug-tracker-mailing-list-interaction

I would leave open this bug post your spec file/SRPM, open up a new thread on
fedora-extras-list discussing reconsidering ntfs support in Extras and post a
link back here to the bug pointing out the Package Review submission.  
Comment 7 Alex Lancaster 2006-02-02 07:30:53 EST
(In reply to comment #5)

> ForbiddenItems mentioned mono as a open issue which has now been resolved. NTFS
> has already been excluded by the counsel. Apparently FAT, Samba etc are
> different from the legal standpoint.Refer to
> http://fedoraproject.org/wiki/ForbiddenItems and

> http://fedoraproject.org/wiki/FedoraLegalIssues for some of the details.

(Running the risk of not following my own advice and avoiding discussion).
Nevertheless it would be nice to have a more detail rationale from the Red Hat
legal counsel about exactly how NTFS is in and FAT than the note there now:

"Microsoft has a number of patents around NTFS. Because of these issues, counsel
feels that adding ntfs support runs the risk of significantly endangering the
project."

Anyway last post from me (will followup on the mailing list).
Comment 8 Thorsten Leemhuis 2006-02-02 07:45:07 EST
(In reply to comment #4)
> [...]
> however my hope is that by
> NOT shipping with core and instead using a kernel module in extras we could
> compromise a little.

Well, normally the same rules apply for Fedora Extras and Fedora Core. For that
reason a "compromise" like that makes no real sense afaics. Either it is allowed
(then it's easier for everyone to enable it in the .config in the kernel from
Core) or not (then it is forbidden in both Core and Extras).

Rahul said all the other important things in #5
Comment 9 Christopher Brown 2006-03-17 07:03:39 EST
Submitted request to gdk as suggested by Rahul - better late than never.

Note You need to log in before you can comment on or make changes to this bug.