Bug 179282 - djvulibre doesn't build under current mock/devel due to modular xorg changes
djvulibre doesn't build under current mock/devel due to modular xorg changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: djvulibre (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-01-29 15:41 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-03 04:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 15:41:33 EST
Description of problem:
djvulibre doesn't build under current mock/devel due to modular xorg changes

The spec file has a BuildRequires of xorg-x11-devel, which is no longer available 
since the change to modular xorg.
Comment 1 Matthias Saou 2006-01-30 05:26:33 EST
Even after fixing the trivial "extra qualification" build errors, djvulibre 3.5.16
still doesn't build properly on FC development :

make[2]: Entering directory `/usr/src/rpm/BUILD/djvulibre-3.5.16/gui/djview'
make[2]: Circular Makefile.dep <- Makefile.dep dependency dropped.
/usr/lib64/qt-3.3/bin/moc ../../gui/indep/QX/qx_imager.cpp -o qx_imager_moc.inc
g++ -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=nocona  -DHAVE_CONFIG_H -I../..
-I../../libdjvu -I./ -I../../gui/indep/QT/ -I../../gui/indep/QX/
-I../../gui/indep/utils/ -I../../gui/shared/QT/ -I../../gui/shared/res/
-I../../gui/shared/utils/  -I. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=nocona 
-pthread -DTHREADMODEL=POSIXTHREADS -I/usr/lib64/qt-3.3/include  -c
../../gui/indep/QX/qx_imager.cpp
/usr/lib64/qt-3.3/include/qnetworkprotocol.h:58: warning: 'class
QNetworkProtocolFactoryBase' has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/qfiledialog.h:78: warning: 'class QFilePreview' has
virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:69: warning: 'struct QUBuffer' has
virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:77: warning: 'struct QUType' has
virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:104: warning: 'struct QUType_Null'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:287: warning: 'struct QUType_enum'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:307: warning: 'struct QUType_ptr'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:326: warning: 'struct QUType_iface'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:345: warning: 'struct QUType_idisp'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:364: warning: 'struct QUType_bool'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:383: warning: 'struct QUType_int'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:403: warning: 'struct QUType_double'
has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:423: warning: 'struct
QUType_charstar' has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucom_p.h:444: warning: 'struct
QUType_QString' has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucomextra_p.h:65: warning: 'struct
QUType_QVariant' has virtual functions but non-virtual destructor
/usr/lib64/qt-3.3/include/private/qucomextra_p.h:87: warning: 'struct
QUType_varptr' has virtual functions but non-virtual destructor
../../libdjvu/GContainer.h: In member function 'DJVU::GCont::HNode*
DJVU::GMapImpl<K, TI>::get_or_create(const K&) [with K = unsigned int, TI = int]':
../../libdjvu/GContainer.h:1206:   instantiated from 'VTYPE&
DJVU::GMapTemplate<KTYPE, VTYPE, TI>::operator[](const KTYPE&) [with KTYPE =
unsigned int, VTYPE = int, TI = int]'
../../gui/indep/utils/col_db.h:111:   instantiated from here
../../libdjvu/GContainer.h:1133: error: invalid initialization of reference of
type 'const DJVU::GPixel&' from expression of type 'const unsigned int'
../../libdjvu/GPixmap.h:451: error: in passing argument 1 of 'unsigned int
DJVU::hash(const DJVU::GPixel&)'
../../libdjvu/GContainer.h: In member function 'DJVU::GCont::HNode*
DJVU::GMapImpl<K, TI>::get_or_create(const K&) [with K = long unsigned int, TI =
DJVU::GP<DXImage>]':
../../libdjvu/GContainer.h:1206:   instantiated from 'VTYPE&
DJVU::GMapTemplate<KTYPE, VTYPE, TI>::operator[](const KTYPE&) [with KTYPE =
long unsigned int, VTYPE = DJVU::GP<DXImage>, TI = DJVU::GP<DXImage>]'
../../gui/indep/QX/qx_imager.cpp:1230:   instantiated from here
../../libdjvu/GContainer.h:1133: error: invalid initialization of reference of
type 'const DJVU::GPixel&' from expression of type 'const long unsigned int'
../../libdjvu/GPixmap.h:451: error: in passing argument 1 of 'unsigned int
DJVU::hash(const DJVU::GPixel&)'
../../libdjvu/GContainer.h: In member function 'DJVU::GCont::HNode*
DJVU::GSetImpl<K>::get(const K&) const [with K = unsigned int]':
../../libdjvu/GContainer.h:1040:   instantiated from 'DJVU::GPosition
DJVU::GSetImpl<K>::contains(const K&) const [with K = unsigned int]'
../../libdjvu/GContainer.h:1168:   instantiated from 'DJVU::GPosition
DJVU::GMapTemplate<KTYPE, VTYPE, TI>::contains(const KTYPE&) const [with KTYPE =
unsigned int, VTYPE = int, TI = int]'
../../gui/indep/utils/col_db.h:111:   instantiated from here
../../libdjvu/GContainer.h:1060: error: invalid initialization of reference of
type 'const DJVU::GPixel&' from expression of type 'const unsigned int'
../../libdjvu/GPixmap.h:451: error: in passing argument 1 of 'unsigned int
DJVU::hash(const DJVU::GPixel&)'
../../libdjvu/GContainer.h: In member function 'DJVU::GCont::HNode*
DJVU::GSetImpl<K>::get(const K&) const [with K = long unsigned int]':
../../libdjvu/GContainer.h:1040:   instantiated from 'DJVU::GPosition
DJVU::GSetImpl<K>::contains(const K&) const [with K = long unsigned int]'
../../libdjvu/GContainer.h:1168:   instantiated from 'DJVU::GPosition
DJVU::GMapTemplate<KTYPE, VTYPE, TI>::contains(const KTYPE&) const [with KTYPE =
long unsigned int, VTYPE = DJVU::GP<DXImage>, TI = DJVU::GP<DXImage>]'
../../gui/indep/QX/qx_imager.cpp:248:   instantiated from here
../../libdjvu/GContainer.h:1060: error: invalid initialization of reference of
type 'const DJVU::GPixel&' from expression of type 'const long unsigned int'
../../libdjvu/GPixmap.h:451: error: in passing argument 1 of 'unsigned int
DJVU::hash(const DJVU::GPixel&)'
make[2]: *** [qx_imager.o] Error 1

Would you by any chance know how to fix this?
Comment 2 Kevin Fenzi 2006-01-30 23:16:26 EST
> Would you by any chance know how to fix this?

Alas, no. ;( 

Might try posting to the extras list and see if any of the g++ gurus there can
figure out whats going on?

This is on x86_64? Does it work now on i386?
Comment 3 Matthias Saou 2006-02-08 10:19:41 EST
The problem had been reported here apparently :
http://sourceforge.net/tracker/index.php?func=detail&aid=1420522&group_id=32953&atid=406583

But after trying a simple rebuild today, it seems to work, so this must have been
a bug in gcc which has been fixed. If things go fine now (which I hope), I'll
be able to close this bug.
Comment 4 Matthias Saou 2006-02-08 10:26:08 EST
So much for the good news... I didn't see the problem today, because the GUI part
was being disabled from my build because of a good old mach/yum bug where i386
packages get installed in x86_64 roots. I'll continue trying to get this bug
fixed...
Comment 5 Kevin Fenzi 2006-06-16 21:40:38 EDT
3.5.17 is out now... no idea if it has anything addressing this, since I can't
seem to find any changelog at all. ;( 

Might be worth a try however.
Comment 6 Matthias Saou 2006-07-03 04:22:29 EDT
Indeed, 3.5.17 seems to fix all the build issues. I've rebuilt FC-5 and devel
packages.

Note You need to log in before you can comment on or make changes to this bug.