Bug 179293 - rebuild-gcj-db hangs when both eclipse-jdt and eclipse-cdt are installed
Summary: rebuild-gcj-db hangs when both eclipse-jdt and eclipse-cdt are installed
Status: CLOSED DUPLICATE of bug 179002
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-29 22:59 UTC by Ian Burrell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 01:41:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stacktrace after gcj-dbtool is stopped while non-responsive (3.45 KB, text/plain)
2006-01-29 22:59 UTC, Ian Burrell
no flags Details

Description Ian Burrell 2006-01-29 22:59:37 UTC
When I install both eclipse-jdt and ecliipse-cdt, rebuild-gcj-db hangs in the
%post script.  I tracked it down to gcj-dbtool deadlocking.

Version-Release number of selected component (if applicable):

libgcj-4.1.0-0.16.x86_64
eclipse-jdt-3.1.1-1jpp_16fc.x86_64
eclipse-cdt-3.0.1-1jpp_3fc.x86_64

How reproducible:

If eclipse-jdt and eclipse-cdt are both installed, rebuild-gcj-db hangs.  If
either or both are removed, then it finishes quickly.

Additional information:

I ran the gcj-dbtool command which was stopped manually.  An strace on
gcj-dbtool shows that it stops with:

futex(0x346f649840, FUTEX_WAIT, 0, NULL

Comment 1 Ian Burrell 2006-01-29 22:59:37 UTC
Created attachment 123854 [details]
Stacktrace after gcj-dbtool is stopped while non-responsive

Comment 2 Ian Burrell 2006-01-30 01:41:08 UTC

*** This bug has been marked as a duplicate of 179002 ***


Note You need to log in before you can comment on or make changes to this bug.