Bug 1792970 - python-neo4j-driver fails to build with Python 3.9: PyTypeObject has no member named tp_print
Summary: python-neo4j-driver fails to build with Python 3.9: PyTypeObject has no membe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-neo4j-driver
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1841743 (view as bug list)
Depends On:
Blocks: F33BetaFreezeException PYTHON39 F33FTBFS F33FailsToInstall 1841745
TreeView+ depends on / blocked
 
Reported: 2020-01-20 13:06 UTC by Miro Hrončok
Modified: 2020-09-14 23:44 UTC (History)
6 users (show)

Fixed In Version: python-neo4j-driver-1.6.2-10.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 23:44:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-20 13:06:02 UTC
python-neo4j-driver fails to build with Python 3.9.0a2.


neo4j/bolt/_io.c:7637:44: error: ‘PyTypeObject’ {aka ‘struct _typeobject’} has no member named ‘tp_print’
 7637 |   __pyx_type_5neo4j_4bolt_3_io_MessageFrame.tp_print = 0;
      |                                            ^
neo4j/bolt/_io.c:7653:50: error: ‘PyTypeObject’ {aka ‘struct _typeobject’} has no member named ‘tp_print’
 7653 |   __pyx_type_5neo4j_4bolt_3_io_ChunkedInputBuffer.tp_print = 0;
      |                                                  ^
neo4j/bolt/_io.c:7665:51: error: ‘PyTypeObject’ {aka ‘struct _typeobject’} has no member named ‘tp_print’
 7665 |   __pyx_type_5neo4j_4bolt_3_io_ChunkedOutputBuffer.tp_print = 0;
      |                                                   ^
Compilation failed, falling back to pure Python.

...

RPM build errors:
error: Empty %files file /builddir/build/BUILD/neo4j-driver-1.6.2/debugsourcefiles.list
    Empty %files file /builddir/build/BUILD/neo4j-driver-1.6.2/debugsourcefiles.list


The tp_print member was removed, it was previously only there for backwards compatibility. See https://bugs.python.org/issue39361


For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01161784-python-neo4j-driver/

For all our attempts to build python-neo4j-driver with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-neo4j-driver/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Victor Stinner 2020-01-20 13:15:02 UTC
> neo4j/bolt/_io.c:7665:51: error: ‘PyTypeObject’ {aka ‘struct _typeobject’} has no member named ‘tp_print’
>  7665 |   __pyx_type_5neo4j_4bolt_3_io_ChunkedOutputBuffer.tp_print = 0;

It looks like code generated by Cython. Maybe the Cython code should be regenerated by the package?

Comment 2 Victor Stinner 2020-01-20 13:19:35 UTC
neo4j/bolt/_io.c has been removed from neo4j-driver 1.7 branch (the whole neo4j/bolt/ subdirectory has been removed).

https://pypi.org/project/neo4j-driver/ 1.7.6 is available: updating the package should be enough to fix this issue.

Comment 3 Ben Cotton 2020-02-11 17:32:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 4 Miro Hrončok 2020-03-16 13:04:49 UTC
Matt, could you please update the package and fix this?

Comment 5 Matt Prahl 2020-03-16 13:10:40 UTC
Hi Miro,
It's on my to do list, but a lot needs to happen to update to 1.7.6. It'll probably be at least a month before I can get to this.

To update to 1.7.6, we must update python-neomodel to 3.3.2 but with a patch on setup.py [3]. We must also package a new Python package called python-neobolt, which used to be part of python-neo4j-driver in 1.6.x, but was split out in 1.7.x. We must also update python-neotime to a newer version. Once all that is complete, then python-neo4j-driver can be updated to 1.7.6.

1 - https://fedoraproject.org/wiki/Changes/Python3.9
2 - https://bugzilla.redhat.com/show_bug.cgi?id=1792970
3 - https://github.com/neo4j-contrib/neomodel/pull/498

Comment 6 Miro Hrončok 2020-03-16 13:17:03 UTC
Let me know if I can help with a package review for python-neobolt.

Comment 7 Miro Hrončok 2020-05-25 13:02:28 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 8 Miro Hrončok 2020-05-29 07:12:12 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 9 Miro Hrončok 2020-06-26 09:03:12 UTC
*** Bug 1841743 has been marked as a duplicate of this bug. ***

Comment 10 Ben Cotton 2020-08-11 13:07:19 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 11 Miro Hrončok 2020-08-22 10:30:51 UTC
Hello. This comment is mass posted to all 16 bugzillas for packages that failed to rebuild with Python 3.9 (and, in most cases, also fail to install on Fedora 33 and 34). Apologies if some of the suggestions or questions don't apply 100%.

Fedora 33 Beta Freeze starts next week on Tuesday, 2020-08-25. I haven't spammed this bugzilla because it is in ASSIGNED, or I've seen upstream has been notified.

Please consider what to do here. Is this failure critical? For example, can a test be temporarily skipped to make this package build? Is it possible to fix or workaround the failure before Fedora 33 Beta? Or before Fedora 33 Final? If not, would it make sense to retire the package (even temporarily) before the release to unblock updates from Fedora 31 or Fedora 32?

In case you need any assistance with a Python-related problem with the build, don't hesitate to let me know and I'll try to have a look.

Thank you!

Comment 12 Miro Hrončok 2020-09-10 17:03:23 UTC
What is the status here?

Comment 13 Miro Hrončok 2020-09-10 18:43:57 UTC
I've figured it out, this is just Cython sources not being regenerated.

Comment 14 Fedora Blocker Bugs Application 2020-09-10 18:46:27 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user churchyard using the blocker tracking app because:

 The package does not install without the fix.

Comment 15 Fedora Update System 2020-09-10 18:53:05 UTC
FEDORA-2020-823c308c4e has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-823c308c4e

Comment 16 Miro Hrončok 2020-09-10 18:56:21 UTC
(In reply to Miro Hrončok from comment #13)
> I've figured it out, this is just Cython sources not being regenerated.

Which was already said by Victor in January and we've got side tracked by the update to 1.7.6, sorry about that.

Comment 17 Fedora Update System 2020-09-11 20:17:58 UTC
FEDORA-2020-823c308c4e has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-823c308c4e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-823c308c4e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Kamil Páral 2020-09-14 14:43:35 UTC
Accepted as a Beta freeze exception:
https://pagure.io/fedora-qa/blocker-review/issue/80

Comment 19 Fedora Update System 2020-09-14 23:44:16 UTC
FEDORA-2020-823c308c4e has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.