Bug 1792971 - Rebase pcp to 5.1.0+
Summary: Rebase pcp to 5.1.0+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: pcp
Version: 8.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Mark Goodwin
QA Contact: Jan Kurik
Apurva Bhide
URL:
Whiteboard:
: 1785101 1788519 1788878 1790415 1790421 1790426 1790427 1790431 1790432 1790437 1790441 1790526 1800545 1805146 1810118 1825386 1825663 1825957 1826020 1837153 1839321 (view as bug list)
Depends On: 1748642
Blocks: 1748643 1788937 1825386 1826047 1835422
TreeView+ depends on / blocked
 
Reported: 2020-01-20 13:06 UTC by Paul Dwyer
Modified: 2021-09-17 12:48 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
.`pcp` rebased to version 5.1.1-3 The `pcp` package has been upgraded to version 5.1.1-3. Notable changes include: * Updated service units and improved `systemd` integration and reliability for all the PCP services. Improved archive log rotation and more timely compression. Archived discovery bug fixes in the `pmproxy` protocol. * Improved `pcp-atop`, `pcp-dstat`, `pmrep`, and related monitor tools along with metric labels reporting in the `pmrep` and export tools. * Improved `bpftrace`, `OpenMetrics`, MMV, the Linux kernel agent, and other collection agents. New metric collectors for the `Open vSwitch` and `RabbitMQ` servers. * New host discovery `pmfind systemd` service, which replaces the standalone `pmmgr` daemon.
Clone Of:
Environment:
Last Closed: 2020-11-04 03:00:37 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4684 0 None None None 2020-11-04 03:01:00 UTC

Comment 2 Nathan Scott 2020-01-31 03:43:03 UTC
Update to reflect a more likely upstream release with this change.  No change to expected RHEL release.

Comment 3 Nathan Scott 2020-03-18 06:24:10 UTC
*** Bug 1790526 has been marked as a duplicate of this bug. ***

Comment 4 Nathan Scott 2020-03-18 06:26:14 UTC
*** Bug 1788519 has been marked as a duplicate of this bug. ***

Comment 5 Nathan Scott 2020-03-18 06:27:32 UTC
*** Bug 1790415 has been marked as a duplicate of this bug. ***

Comment 6 Nathan Scott 2020-03-18 06:27:49 UTC
*** Bug 1790421 has been marked as a duplicate of this bug. ***

Comment 7 Nathan Scott 2020-03-18 06:28:11 UTC
*** Bug 1790422 has been marked as a duplicate of this bug. ***

Comment 8 Nathan Scott 2020-03-18 06:28:40 UTC
*** Bug 1790426 has been marked as a duplicate of this bug. ***

Comment 9 Nathan Scott 2020-03-18 06:29:20 UTC
*** Bug 1790427 has been marked as a duplicate of this bug. ***

Comment 10 Nathan Scott 2020-03-18 06:29:24 UTC
*** Bug 1790431 has been marked as a duplicate of this bug. ***

Comment 11 Nathan Scott 2020-03-18 06:29:43 UTC
*** Bug 1790432 has been marked as a duplicate of this bug. ***

Comment 12 Nathan Scott 2020-03-18 06:29:58 UTC
*** Bug 1790433 has been marked as a duplicate of this bug. ***

Comment 13 Nathan Scott 2020-03-18 06:30:16 UTC
*** Bug 1790441 has been marked as a duplicate of this bug. ***

Comment 15 Mark Goodwin 2020-03-19 01:09:44 UTC
*** Bug 1785101 has been marked as a duplicate of this bug. ***

Comment 16 Mark Goodwin 2020-03-19 04:19:34 UTC
*** Bug 1805146 has been marked as a duplicate of this bug. ***

Comment 17 Nathan Scott 2020-04-21 00:02:38 UTC
*** Bug 1825663 has been marked as a duplicate of this bug. ***

Comment 18 Nathan Scott 2020-04-21 00:27:51 UTC
*** Bug 1790437 has been marked as a duplicate of this bug. ***

Comment 19 Nathan Scott 2020-04-21 00:28:33 UTC
*** Bug 1790450 has been marked as a duplicate of this bug. ***

Comment 20 Nathan Scott 2020-04-21 00:29:05 UTC
*** Bug 1790452 has been marked as a duplicate of this bug. ***

Comment 21 Nathan Scott 2020-04-21 00:30:42 UTC
*** Bug 1800545 has been marked as a duplicate of this bug. ***

Comment 22 Nathan Scott 2020-04-29 23:55:11 UTC
*** Bug 1826020 has been marked as a duplicate of this bug. ***

Comment 23 Nathan Scott 2020-04-29 23:58:19 UTC
*** Bug 1788878 has been marked as a duplicate of this bug. ***

Comment 24 Mark Goodwin 2020-05-04 05:48:41 UTC
*** Bug 1810110 has been marked as a duplicate of this bug. ***

Comment 25 Mark Goodwin 2020-05-04 05:52:33 UTC
*** Bug 1810118 has been marked as a duplicate of this bug. ***

Comment 26 Mark Goodwin 2020-05-05 02:49:51 UTC
*** Bug 1825957 has been marked as a duplicate of this bug. ***

Comment 27 Mark Goodwin 2020-05-06 02:04:43 UTC
YUM repo for SCRATCH build of pcp-5.1.0 (first rebase) for RHEL-8.3 :
http://brew-task-repos.usersys.redhat.com/repos/scratch/mgoodwin/pcp/5.1.0/1.el8/pcp-5.1.0-1.el8-scratch.repo

Here's the changelog - please let me know if I've missed any BZs :

[mgoodwin@rhel82 ~]$ rpm -q --changelog pcp| head -28
* Wed May 06 2020 Mark Goodwin <mgoodwin@redhat.com> - 5.1.0-1
- Improve pmlogger and pmie system log messages (BZ 1806428)
- Missing dep of pcp-pmda-dbping on perl-DBI (BZ 1790421)
- Missing dep of pcp-pmda-ds389log on 389-ds-base (BZ 1790422)
- Missing dep of pcp-pmda-gpsd on perl-JSON and perl-Time-HiRes (BZ 1790426)
- Missing dep of pcp-pmda-lmsensors on lm_sensors (BZ 1790427)
- Missing dep of pcp-pmda-redis on perl-autodie (BZ 1790431)
- Missing dep of pcp-pmda-smart on smartmontools (BZ 1790432)
- Missing dep of pcp-pmda-snmp on net-snmp-perl (BZ 1790433)
- SELinux issues with pcp-pmda-zimbra (BZ 1790437)
- Missing dep of pcp-pmda-pdns on perl-Time-HiRes (BZ 1790441)
- Installation of pcp-pmda-netcheck causes SELinux issue (BZ 1790450)
- Installation of pcp-pmda-samba causes SELinux issues (BZ 1790452)
- Some PMDAs are missing dependency on PCP (BZ 1790526)
- pmieconf randomly fails (BZ 1800545)
- collectl2pcp does not handle large collectl archives well (BZ 1785101)
- Missing dep of pcp-pmda-redis on perl-autodie and perl-Time-HiRes (BZ 1788519)
- Can not install pcp-pmda-activemq, wrong location of RESTClient (BZ 1788878)
- Missing dep of pcp-pmda-bind2 on various perl packages (BZ 1790415)
- pmlogger_daily_report causing PCP upstream testsuite to fail (BZ 1805146)
- Missing selinux rules preventing pcp-pmda-named runing rndc(BZ 1825663)
- SELinux is preventing PostgreSQL PMDA to collect metrics (BZ 1825957)
- pmnewlog generates inaccessible config file (BZ 1810110)
- pmnewlog is causing PCP testsuite to hang (BZ 1810118)
- pmdakvm: debugfs access is restricted (BZ 1824297)
- error starting pmlogger; pid file not owned by root (BZ 1761962)
- Update to latest PCP 5.1.0-1 upstream sources.

Comment 31 Mark Goodwin 2020-05-11 04:14:53 UTC
Adding Rebase keyword (for future rpmdiff runs)

Comment 33 Mark Goodwin 2020-05-21 00:49:34 UTC
*** Bug 1788937 has been marked as a duplicate of this bug. ***

Comment 34 Andreas Gerstmayr 2020-05-28 14:16:50 UTC
*** Bug 1839321 has been marked as a duplicate of this bug. ***

Comment 35 Nathan Scott 2020-06-18 05:50:54 UTC
*** Bug 1837153 has been marked as a duplicate of this bug. ***

Comment 37 Nathan Scott 2020-09-13 22:51:02 UTC
*** Bug 1825386 has been marked as a duplicate of this bug. ***

Comment 44 errata-xmlrpc 2020-11-04 03:00:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (pcp bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4684


Note You need to log in before you can comment on or make changes to this bug.