Bug 179299 - fluxbox doesn't build under current devel/fc5 mock due to modular xorg changes
fluxbox doesn't build under current devel/fc5 mock due to modular xorg changes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fluxbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
https://sourceforge.net/tracker/index...
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-01-29 18:41 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 03:05:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 18:41:41 EST
Description of problem:
fluxbox doesn't build under current devel/fc5 mock due to modular xorg changes

End of the mock build.log: 

checking for socket in -lsocket... no
checking for X... no
configure: error: Fluxbox requires the X Window System libraries and headers.
error: Bad exit status from /var/tmp/rpm-tmp.88042 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.88042 (%build)

Check your configure script to see what its looking for, but in the past I have
seen configure need a BuildRequires: imake libXt-devel for this test. 

Full build.log on request.
Comment 1 Andreas Bierfert 2006-01-29 20:31:04 EST
Actually it is fixed locally. It does not compile because of big c++ problems
which I have reported upstream. Will leave this open as a tracker. Thanks.
Comment 2 Andreas Bierfert 2006-03-02 03:05:11 EST
Fixed and pushed.

Note You need to log in before you can comment on or make changes to this bug.