Bug 1792998 - Add to epel 8: keepass package please.
Summary: Add to epel 8: keepass package please.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: keepass
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Timotheus Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1849862 (view as bug list)
Depends On: 1752940 1774690
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-20 13:29 UTC by boboshaq
Modified: 2020-08-11 18:25 UTC (History)
6 users (show)

Fixed In Version: keepass-2.45-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-11 18:25:42 UTC
Type: Bug


Attachments (Terms of Use)

Description boboshaq 2020-01-20 13:29:05 UTC

Comment 1 Fedora Update System 2020-05-14 20:15:46 UTC
FEDORA-EPEL-2020-dcffa3c4bb has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-dcffa3c4bb

Comment 2 Fedora Update System 2020-05-15 04:41:42 UTC
FEDORA-EPEL-2020-dcffa3c4bb has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-dcffa3c4bb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2020-05-30 00:41:00 UTC
FEDORA-EPEL-2020-dcffa3c4bb has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 boboshaq 2020-06-18 10:21:24 UTC
Problem: conflicting requests
 - nothing provides xdotool needed by keepass-2.45-1.el8.x86_64

I get above error when I tried to install keepass from epel 8 on Centos 8

Comment 5 boboshaq 2020-06-18 10:27:38 UTC
I have enabled those repos:
AppStream                  CentOS-8 - AppStream
BaseOS                     CentOS-8 - Base
PowerTools                 CentOS-8 - PowerTools
Stream-AppStream           CentOS-Stream - AppStream
Stream-BaseOS              CentOS-Stream - Base
Stream-extras              CentOS-Stream - Extras
adobe-linux-x86_64         Adobe Systems Incorporated
epel                       Extra Packages for Enterprise Linux 8 - x86_64
epel-modular               Extra Packages for Enterprise Linux Modular 8 - x86_64
extras                     CentOS-8 - Extras
rpmfusion-free-updates     RPM Fusion for EL 8 - Free - Updates
teamviewer                 TeamViewer - x86_64

Comment 6 Timotheus Pokorra 2020-06-23 04:02:36 UTC
Can you please file a ticket for xdotool, to be made available for Epel8?

Or should we drop the dependancy?

Comment 7 Timotheus Pokorra 2020-06-23 04:02:52 UTC
*** Bug 1849862 has been marked as a duplicate of this bug. ***

Comment 8 tomislav.parcina 2020-07-02 14:31:20 UTC
(In reply to Timotheus Pokorra from comment #6)
> Can you please file a ticket for xdotool, to be made available for Epel8?
> 
> Or should we drop the dependancy?

Is xdotool really necessary for keepass, or it is unnecessary dependency? One way or another it is bug in this package. If it is in repository, and his dependency is not, then it should be fixed (dependency should be added to repository as well). And if it lists unnecessary dependency, than dependency list should be fixed.

Best regards.

Comment 9 Peter Oliver 2020-07-02 16:41:41 UTC
(In reply to tomislav.parcina from comment #8)

> Is xdotool really necessary for keepass, or it is unnecessary dependency?

The KeePass installation instructions, https://keepass.info/help/v2/setup.html#mono, says that it is necessary for the auto-type functionality to work on X11.  I guess we could do something complicated with RPM boolean dependencies to make it merely a Recommends if Wayland is installed.

Comment 10 tomislav.parcina 2020-07-03 06:28:11 UTC
(In reply to Peter Oliver from comment #9)
> The KeePass installation instructions,
> https://keepass.info/help/v2/setup.html#mono, says that it is necessary for
> the auto-type functionality to work on X11.  I guess we could do something
> complicated with RPM boolean dependencies to make it merely a Recommends if
> Wayland is installed.

If it is possible to do it this way, I guess it would be the right way to do it.

Comment 11 boboshaq 2020-07-14 15:00:52 UTC
Hi!

Now xdotool is in epel 8, so I was installed keepass without problem. I use "Standard (X11 display server) on Xorg" in my Centos 8, because on Wayland display servers (Standard and Classic) auto-typeing is not working. For me, auto-typeing is one of most wanted function in password manager program.

Regards!


Note You need to log in before you can comment on or make changes to this bug.