Bug 1793007 - python-rmtest fails to build with Python 3.9: Test failure ['PONG', 'PONG', 'PONG'] != [True, True, True]
Summary: python-rmtest fails to build with Python 3.9: Test failure ['PONG', 'PONG', '...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rmtest
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-01-20 13:45 UTC by Miro Hrončok
Modified: 2020-03-26 01:18 UTC (History)
5 users (show)

Fixed In Version: 1.0.1-1.fc33 python-rmtest-1.0.1-1.fc32 python-rmtest-1.0.1-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-17 09:55:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-20 13:45:13 UTC
python-rmtest fails to build with Python 3.9.0a2.

======================================================================
FAIL: testCluster (test.ClusterTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/rmtest-1.0.0/test.py", line 61, in testCluster
    self.assertListEqual(['PONG', 'PONG', 'PONG'], res)
AssertionError: Lists differ: ['PONG', 'PONG', 'PONG'] != [True, True, True]
First differing element 0:
'PONG'
True
- ['PONG', 'PONG', 'PONG']
+ [True, True, True]
----------------------------------------------------------------------
Ran 4 tests in 6.117s
FAILED (failures=1)

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01162055-python-rmtest/

For all our attempts to build python-rmtest with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-rmtest/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Nathan Scott 2020-01-23 01:06:18 UTC
Hmm, I wonder if this is actually a regression in behaviour in the python-redis package that python-rmtest uses.  Looks like f31 has an older version to what was used in this build (3.2.1 vs 3.3.8).

Comment 2 Ben Cotton 2020-02-11 17:28:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 3 Miro Hrončok 2020-03-16 13:05:49 UTC
> Hmm, I wonder if this is actually a regression in behaviour in the python-redis package that python-rmtest uses.

Any update on that?

Comment 4 Nathan Scott 2020-03-17 06:16:36 UTC
(In reply to Miro Hrončok from comment #3)
> > Hmm, I wonder if this is actually a regression in behaviour in the python-redis package that python-rmtest uses.
> 
> Any update on that?

Yep, its definitely the cause.  We're just going to have to deal with it however, as we want rmtest to work with any version of the redis client.  I've pushed a fix to rmtest upstream & will push a build fix into Fedora shortly.

cheers.

Comment 5 Fedora Update System 2020-03-17 07:19:50 UTC
FEDORA-2020-9b5d7d0ff2 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9b5d7d0ff2

Comment 6 Miro Hrončok 2020-03-17 09:55:10 UTC
Than You.

Comment 7 Fedora Update System 2020-03-18 02:38:12 UTC
python-rmtest-1.0.1-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-10b5b46218

Comment 8 Fedora Update System 2020-03-18 02:49:06 UTC
python-rmtest-1.0.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9b5d7d0ff2

Comment 9 Fedora Update System 2020-03-25 16:15:44 UTC
FEDORA-2020-10b5b46218 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-03-26 01:18:58 UTC
FEDORA-2020-9b5d7d0ff2 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.